Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I have an iPhone 3G which ran iOS 3.1.3 whited00r custom Firmware. I tried to update it to iOS 4.1.2 but inevitably failed. At first, I was able to erase the software already on the device and restore the device to stock 4.1.2 but when trying to jailbreak the phone won't boot. After hours on end the phone is stuck in "WTF Mode" and every attempt to jailbreak the phone again results in the device returning back to WTF Mode. I have tried: redsn0w 0.9.14b2, 0.9.15b3 and 0.9.6b6. The jailbreaking process took place but always ended in failure. Now the phone is just stuck in WTF Mode. Trying to restore any custom software or factory default software on the phone just results in iTunes hanging on "Restoring Firmware" or "1600" error on iTunes respectively. Right now, I'm wondering if this piece of junk is scrap to me now because its the last phone I got. Anyone else has this problem or anyone who understands my situation and knows a way to solve it, please help.

asked 02 May '13, 04:04

Jagofr's gravatar image


closed 16 Dec '13, 13:13

spockers's gravatar image

spockers ♦♦

The question has been closed for being "Solved" by spockers, 16 Dec '13, 13:13


answered 02 May '13, 19:52

xfantuhm's gravatar image


edited 02 May '13, 19:53

the link is dead

(03 May '13, 07:49) Jagofr Jagofr's gravatar image

Okay.. So.. I've figured out how to get my phone to restore:

Drain the battery, Set in DFU Mode, When you open iTunes it should put automatically set iPhone to WTF Mode, then go find your hosts file and change "" or something like that and put a "#" before it. Then you can restore back to normal firmware.. However I've encountered a different problem.. I can't jailbreak now


answered 04 May '13, 17:14

Jagofr's gravatar image


THE EXACT THING HAPPENED TO ME. Redsn0w identifies as a "1st Gen Device"

(04 May '13, 18:26) xfantuhm xfantuhm's gravatar image

You should both be using redsn0w 0.9.14b2, not the latest, as 15b3 doesn't play well with the iPhone 3G.

(04 May '13, 18:55) spockers ♦♦ spockers's gravatar image

I had this issue(Error 3194) while jailbreak my iphone 3g. while performing the steps provided for jailbreak i was struck in the WTF mode. it is resolved by auto-exit mode in preference in the Jailbreak(redsnow) .

iPhone 3G stuck in WTF Mode


answered 16 Dec '13, 12:59

Andyvs's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 02 May '13, 04:04

Seen: 9,741 times

Last updated: 16 Dec '13, 13:13

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.