Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

evasi0n7 can jailbreak iOS 7.0-7.0.6 untethered. p0sixspwn can jailbreak iOS 6.1.3-6.1.5 untethered (see here for 6.1.6).
How to jailbreak iOS 7.0-7.0.6 (and fix problems). iOS 7.1.x is not jailbreakable, except an unsupported tethered iPhone 4 jailbreak.
Restoring or updating will update your device to iOS 7.1.1 and remove your jailbreak. There is no way to downgrade from iOS 7.1.x to 7.0.x.

Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to chat, you can join us here (irc.freenode.net #JailbreakQA). Chat rules.

My iPhone 3GS is currently running 4.3.3 with the iPad baseband (06.15.00). It's obviously jailbroken and I need to maintain the baseband for unlocking purposes.

I'm trying to update my iOS to 5.x or preferably 6.x, I don't really mind which version but I have stock firmware files for 5.1.1, 6.0, 6.1 and 6.1.2 already downloaded.

I've tried the sn0wbreeze and redsn0w methods. Using sn0wbreeze I get error 3194 for all, I have tried the hosts file fix and this only seems to do something with 5.1.1 which seems to get a bit further before running into error 1600.

When using redsn0w I get to putting it into DFU mode and then at the next step I'm told there are no blobs found for the firmware. I know I haven't got any blobs because I've never been on this firmware to create/save them - that seems like something you would only have if you were downgrading...

How can I work around this problem? I just need a method of upgrading that doesn't require blobs that maintains my baseband so that I can carrier unlock it.

1

Restoring to any iOS version other than the latest requires SHSH blobs, whether it's upgrading or downgrading.

You may already have SHSH Blobs and not know it. Open Cydia and at the top of the home page it should have versions listed, like so.

(05 Apr '13, 10:04) cybr1d ♦ cybr1d's gravatar image

Thank you for pointing that out. I had a look on my Cydia and found that I had 5.1.1 listed there. I used redsn0w again with the stock 5.1.1 firmware and was able to select 'remote' blobs, these downloaded and the program progressed a bit until I ran into 'unexpected error 2831'

EDIT: My phone also seems to be stuck on the usb -> itunes logo now

(05 Apr '13, 10:23) plagiarypoet plagiarypoet's gravatar image
1

See my answer below (decided it was too much for a comment).

Let me know if you have issues, get confused, or have errors ;)

(05 Apr '13, 10:44) cybr1d ♦ cybr1d's gravatar image

No idea what error 2831 is.. but the usb -> iTunes logo is called recovery mode.

Try rebooting the computer and give sn0wbreeze a shot now:

Edit: See comments for what was used instead.

link

answered 05 Apr '13, 10:43

cybr1d's gravatar image

cybr1d ♦
24.1k255536

edited 05 Apr '13, 13:15

Thanks for replying again. I managed to get it back into DFU mode (I think) from recovery mode - home & power until powers off then quick release and follow usual DFU procedure. After this I thought I'd give redsn0w another shot. Did everything the same but somehow it followed all the way through and my phone is now running 5.1.1.

I don't think it activated - if I'm using that term right. It's loaded up to the set-up process and is asking for the proper Carrier SIM card.

I'm not sure what my next step should be - I will have a search but if you have any suggestions then I am very grateful for the help!

(05 Apr '13, 11:08) plagiarypoet plagiarypoet's gravatar image
1

ah right, redsn0w won't activate by default. You'll need to jailbreak.

Redsn0w- Extras- Select IPSW: Choose the stock Apple 5.1.1. Click Back, then "jailbreak".

You will come to checkboxes and check "install Cydia" and "downgrade from iPad baseband" then hit next. (just trust me on the baseband downgrade, 5.13 is better than 6.15)

(05 Apr '13, 11:12) cybr1d ♦ cybr1d's gravatar image

Thanks, I followed your instructions through, I can now access my phone and it is running 5.1.1 with the lower baseband.

I did the restore backup on itunes and that seems to have brought my contacts and pictures across. My apps seem to be missing and I think the hard drive capacity has reduced a bit - this isn't a major problem although I wonder if there is a way to bring everything back?

Do I need to re-unlock my phone now?

(05 Apr '13, 12:09) plagiarypoet plagiarypoet's gravatar image
1

Just install Ultrasn0w from Cydia to unlock again.

If you didnt have the apps/music etc stored in iTunes, you'll have to redownload them. Anything you've bought you can re-download for free. The same goes Cydia Apps/tweaks (minus storing them in iTunes). You would have needed to use a Cydia back-up app prior to restoring.

(05 Apr '13, 12:14) cybr1d ♦ cybr1d's gravatar image
1

On a side note, because you 'hacktivated' (activated without the official sim) you should Use SAM to get proper activation.

Hope this answers and fixes everything ;)

(05 Apr '13, 12:19) cybr1d ♦ cybr1d's gravatar image

Okay, I'll do those, in that order?

Why is I want to use this SAM? What's the benefit?

(05 Apr '13, 12:32) plagiarypoet plagiarypoet's gravatar image
1

The order doesn't matter, but 'hacktivating' usually breaks push notifications and can have negative effects on battery life. (because the phone is constantly looking for activation tickets that don't exist). SAM fixes hacktivation.

(05 Apr '13, 13:04) cybr1d ♦ cybr1d's gravatar image

Thanks for the explanation, I did it all, not sure that the SAM thing went through properly but everything seems to be working well. If I run into those problems then I'll come back to it. Thanks for all your help, I'm sure I would have been stuck for ages otherwise! :)

(05 Apr '13, 13:10) plagiarypoet plagiarypoet's gravatar image

Awesome :) It sounds like all worked perfectly. Glad to have helped.

(05 Apr '13, 13:14) cybr1d ♦ cybr1d's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,522
×1,452
×696
×617
×472
×294
×73
×46
×38

Asked: 05 Apr '13, 06:48

Seen: 6,583 times

Last updated: 05 Apr '13, 13:15

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.