Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

1
1

Hi All, suddenly my iMessage, Face time and push notifications have stopped working. iMessage and FaceTime says 'Waiting for Activation' And Push says to connect to to iTunes. But even after connecting to iTunes, problem hasn't resolved. I searched online which says to do restore, since I am on iOS 6.1.2 jailbroken, I don't want to restore it to iOS 6.1.3 for obvious reasons. How can I make all the 3 services work again?

You might mention the device.

(28 Mar '13, 00:24) spockers ♦♦ spockers's gravatar image

It's iPhone 5

(28 Mar '13, 00:30) Preetvarunsingh Preetvarunsingh's gravatar image

Try resetting all settings in the Settings app. Do not do the one with the word erase in it.

(28 Mar '13, 00:45) spockers ♦♦ spockers's gravatar image

Nope it dint work. :(

(28 Mar '13, 01:32) Preetvarunsingh Preetvarunsingh's gravatar image

Are you using an official carrier?

(28 Mar '13, 01:36) spockers ♦♦ spockers's gravatar image

Mine is a unlocked iPhone

(28 Mar '13, 01:43) Preetvarunsingh Preetvarunsingh's gravatar image

Maybe I guess I have to restore. ????

(28 Mar '13, 01:52) Preetvarunsingh Preetvarunsingh's gravatar image

Unlocked using r-sim interposer?

(28 Mar '13, 01:52) justinred ♦ justinred's gravatar image

No no. It's official Unlocked. Bought from Apple Store at full price

(28 Mar '13, 01:55) Preetvarunsingh Preetvarunsingh's gravatar image

I've got similar Problems on my iPhone 5 with iOS 6.1.2 and JB. IPusher App does not work and some others have problems, too but not all. Deinstalling these Apps and reinstalling did unfortunately not fix that problem. As restoring to 6.1.2 is not possible what else could I try? It seems to me that apps installed bevore JB have no problems.

(12 Apr '13, 13:34) KingTutt KingTutt's gravatar image

I got my problem solved. I had deleted Keychain-2.db file via ifile and since then push,iMessage, FT stopped working. I did not know there is a trash in ifile from where we can restore the file and I restored it and got all services back that moment only. Now no problem with any app or whatsoever.

(12 Apr '13, 13:49) Preetvarunsingh Preetvarunsingh's gravatar image

The question has been closed for being "OLD" by theiphoneguy, 08 Aug '14, 03:26


Try these trouble shooting measures:

  1. Settings>Airplane Mode>On>Off
  2. Settings>General>Reset>Reset Network Settings
  3. Settings>iMessage>On>Off>On
  4. Verify you have working data on your account (not wifi) by openning Safari and connect to Google News
  5. Power off>Power on

One of those should work

link

answered 12 Apr '13, 14:39

JuergenWest's gravatar image

JuergenWest ♦
12.1k383348

Thanks for your suggestions, here are my results: I tested with iPusher. Not working means that iPusher says only "Please wait..." after pressing button

1) did not change anything -> not working

2) last Option to test, because I will have to enter all WLAN PW again -> scheduled but less hope

3) Disabled and Enanled again. After a moment iMessage is registered again. iPusher not working

4) I opened Google News using Dataconnection (not Wifi) and switched to iPusher. Did not work

5) did not change anything -> not working

IPusher App should be OK, tested everytime with an iPad 4 Wifi on iOS 6.1.3 which worked fine. Push Notifications from "MyDealZ" App are working fine, from "AppTickeker Push" App not. iMessages are working fine, Push Notifications from "App of the Day" work fine from "ZDFheute" App not. I don't understand that some are working and others not. I never used iFile or some thing similar. Any further options?

(12 Apr '13, 18:12) KingTutt KingTutt's gravatar image

sounds like you deviated from the troubleshooting list, try again without deviations, also add removing any profiles in Settings app. eg unlockit.co.nz, etc.

(12 Apr '13, 19:14) JuergenWest ♦ JuergenWest's gravatar image

OK, I tried again and followed exactly your troubleshooting list. 1. First set Airplane Mode to On and Off again

  1. I removed the only Profile from my device with Settings.app which contains 802.11x credentials (EAP-TLS) for company use. I never visited unlockit.co.nz before. After that I reset the network settings (the device reboot automatically after that)

  2. As iMessages where still On I put them Off and On again (iMessages did register new)

  3. With working data I connected to Google News (worked fine)

  4. I shut down the device and put it on again

  5. I reinstalled the iPusher App to see if any of the steps solved the problem but the iPusher App still doesn't work. At 9AM I got one Push Notifications from "App of the Day". I tested iPusher App a second time but it only says "Please wait..." and the App is definitely allowed to sent PushNotifications (Enabled in Message Center and on Lockscreen). The only thing I recognized was that IPusher App did not ask me again if it is allowed to sent PushNotifications to me after reinstalling. The previous settings were not touched during re-installation process

I hope that I did understand your instructions properly. And further ideas?

(15 Apr '13, 05:55) KingTutt KingTutt's gravatar image

Right, after analysing the push behaviour for 24hours on this iPhone 5 with iOS 6.1.2 I can observe still the same. The above procedure did not change anything. Some apps are working fine with Push Notifications like "Twitter" "MyDealZ" "Tagesschau". Others do not work like "iPusher" "ZDFHeute" "App Ticker Push". Some apps were installed on iPhone before JB and some after applying JB. The phone is officially unlocked (bought from Apple store), and only a few Apps from Cydia are installed, nothing special.

Is there a possibility to reset the Push Token for an app without restoring the device? When reinstalling iPusher I'm never asked again if I want to allow Push Notifications for that App, this must be stored somewhere on device. I was only asked the very first time. Maybe it is possible to reset this behaviour somewhere in the file system? Any expert on push notifications here?

link

answered 16 Apr '13, 01:22

KingTutt's gravatar image

KingTutt
413

-1

I know I'm late with this answer but I'll post it here just in case you (or someone else) still needs it. I locked myself out of my iPhone 4S. It was disabled and was asking me to do an iTunes restore and activation in order to use it, but of course that was out of question because that would erase everything, kill my jailbreak, and the worst, it would install iOS 7 which I absolutely don't want. So what I did was delete keychains-2.db with its backup file, and com.apple.springboard.plist. It worked like a charm, I was no longer locked out, but I noticed that the push notifications and the YouTube app were dead. I have read many things about this problem but I mostly found help for hacktivated users, which wasn't my case. I lived without push until I discovered that a jailbreak utility called SAM can deactivate your device, requiring you to activate it again once rebooted. Deleting the system files caused me to lose my so-called "push tokens" which are a certificate from Apple which are basically required in order to get push nottys. However, you get those tokens upon activating your iPhone, so deactivating and activating it again will get you those tokens back. All you need to do is download SAM, press deactivate iPhone, then reboot and follow the instructions. None of your data/settings will ever be lost (you lose wifi passwords and some settings when deleting keychains though). Oh yea, and this won't work on a stolen iPhone because it will ask you for the Apple ID/password of the owner, and if that isn't you, well, then you should not steal phones/buy stolen ones. I hope this helps anyone with this problem out there.

Some specs:

Hardware: iPhone 4S (A1387)

Software: iOS 6.1.3 + p0sixspwn jailbreak

link

answered 08 Aug '14, 02:47

JiGSaW113's gravatar image

JiGSaW113
4.1k967108

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,351
×2,358
×484
×288
×162
×111
×92
×73

Asked: 28 Mar '13, 00:13

Seen: 10,144 times

Last updated: 08 Aug '14, 03:26

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.