Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i bought my iphone 4 4.2.1 from apple store newyork and when i jailbreak it with greenpois0n it say's the error (unable to find fs_mount unable to find fs_unmount these error were found and then i jailbreak my iphone 4 with redsnow 0.9.7b6 after that my iphone is tethered and then i again used greenpois0n it again shows me the same errors given above now plz help me how can i make my iphone 4 untethered on 4.2.1 i have iphone 4 firmware 4.2.1 baseband 03.10.01 carier at&t 9.0 plz help me solve this issue

asked 21 Feb '11, 07:35

harib's gravatar image

harib
1517219

I did the same procedure, with the same errors, on my iPod touch 4g. The trick is to keep holding home until you see a screenfull of text after the errors. It's the easiest/quickest thing to try.

(21 Feb '11, 08:12) spockers ♦♦ spockers's gravatar image

Ok. so if you use Windows then use either GP or sn0wbreeze (I have no experience of this one)

Your baseband will not change if you restore to stock 4.2.1 as that is the one that comes with that version of firmware, there is no point preserving it in your case either, that only currently has an impact on iphone 4 owners who bought theirs when they came out and had/have the 1.59.xx unlockable baseband, something worth preserving. As for any new unlock for your baseband, all we know is that the Dev Team will release what they have after Apple release 4.3, so make sure not to update to that when it's out as that will update your baseband past the one you have now and may ruin your chances of an unlock.

Restoring to stock firmware via itunes kills/removes any jailbreak/unlock you may have had, this is especially good if you need to take your idevice in for service.

I also strongly recommend you download TinyUmbrella, connect your iphone and click 'save shsh' no need to be jailbroken for this.

link

answered 21 Feb '11, 08:17

venusanann's gravatar image

venusanann
13.3k11618

edited 21 Feb '11, 08:22

Those errors are normal. Just wait about 30 seconds after the errors, you should get a full page of text.

link

answered 21 Feb '11, 07:43

spockers's gravatar image

spockers ♦♦
69.9k3911660

no after 10 seconds apple logo appears and everything goes back

link

answered 21 Feb '11, 07:46

harib's gravatar image

harib
1517219

That Redsn0w jailbreak is the monte version, I haven't used it myself but MuscleNerd says to restore to stock 4.2.1 before using GP, I don't think it will go over the top (I could be wrong, but I trust Musclenerd). I just checked the download link for that version of Redsn0w and it was Mac only for me, so if you can't get GP to work and you are using a Mac, just use latest PwnageTool for untethered jailbreak......FWIW I had no problem using GP on my iphone 4.

link

answered 21 Feb '11, 07:48

venusanann's gravatar image

venusanann
13.3k11618

edited 21 Feb '11, 08:24

so i have to restore my iphone to custom 4.2.1 firmware then use it with GP?

link

answered 21 Feb '11, 07:50

harib's gravatar image

harib
1517219

No not custom, if you want to try GP again then it will be best to kill Redsn0w JB by restoring to stock 4.2.1 in itunes, if you want to use PwnageTool then I don't think it matters restoring to stock 4.2.1 (though you can if you wish) beforehand as the custom ipsw will be installed as a restore anyway and so kill the Redsn0w JB.

link

answered 21 Feb '11, 07:58

venusanann's gravatar image

venusanann
13.3k11618

i am using windows and after restoring to stock 4.2.1 then my baseband will update as well? and can i use snowbreeze for 4.2.1? and how can i presarve my baseband thorough snowbreeze? and can you when will unlock for 03.10.01 baseband will come?and plz explain about killing redsnow JB

link

answered 21 Feb '11, 08:09

harib's gravatar image

harib
1517219

baseband 3.10.01 is the latest for iPhone 4, you don't need to preserve anything for the time being ..... that is until the 4.3 firmware is released.

link

answered 21 Feb '11, 08:20

knightz4u's gravatar image

knightz4u
4.9k91828

so what i have to do is just click retore when i connect my iphone to itunes or what else i have to do to restore it? and after restoring will my baseband will upgrade or not? and can you tell me the procedure for restoring to stock 4.2.1?

link

answered 21 Feb '11, 08:25

harib's gravatar image

harib
1517219

Clicking restore will put you at stock 4.2.1. You baseband will remain the same. I still think you should try my suggestion first though, it's much quicker and if it fails you've lost nothing. (See my comment under your original question)

(21 Feb '11, 08:29) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×96

Asked: 21 Feb '11, 07:35

Seen: 3,727 times

Last updated: 21 Feb '11, 08:29

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.