Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

When i tried to download OpenSSH on Cydia, its give me error. Does anyone have the same problem as i do? iPhone 4 IOS 4.2.1

asked 19 Feb '11, 05:42

cvliew's gravatar image

cvliew
32412713133


What's the error?

link

answered 19 Feb '11, 05:45

venusanann's gravatar image

venusanann
13.3k11618

I open Cydia->Search->Type OpenSSH, when I wanted to install, it pop-up "Size Mismatch" error. I was unabled to install OpenSSH.

Thanks in advance

(19 Feb '11, 06:54) cvliew cvliew's gravatar image

Keep trying, in my experience size mismatch is on repo end and not yours

link

answered 19 Feb '11, 07:00

venusanann's gravatar image

venusanann
13.3k11618

edited 19 Feb '11, 07:02

I had tried plenty of times but it is still the same.

(19 Feb '11, 07:12) cvliew cvliew's gravatar image

Have you tried with other apps from different repos, just as test?

link

answered 19 Feb '11, 07:16

venusanann's gravatar image

venusanann
13.3k11618

No, I haven't tried. can u recommend one to me....repos

(19 Feb '11, 16:12) cvliew cvliew's gravatar image

Crikey, is openssh still not installing for you? what I meant was to download anything from another repo, like Modmyi or Bigboss, and see if you get the same error sort of a process of elimination, and then just uninstall it. There are plenty of packages under 'sections' in Cydia.

(19 Feb '11, 16:22) venusanann venusanann's gravatar image

It sounds like you have an incomplete install of Cydia. If you used loader to install Cydia, that's probably the reason. Loader has lots of issues, probably due to the server it gets Cydia from being overloaded. Try to install something else in Cydia, say, SBSettings (essential one to have anyway). If that works, your Cydia is probably OK. SBSettings is in the BigBoss repo, which is one of the default repos. OpenSSH is in Telesphoreo, which is also a default repository. For what it's worth, I just downloaded OpenSSH with no problems.

link

answered 19 Feb '11, 16:22

spockers's gravatar image

spockers ♦♦
69.9k3911660

For your info, previously, I'm using Redsn0w 0.9.6 tethered jailbreak and once new JB tools was released, I used GP RC5-B4 (Window XP)run on top of it without restoring and at the end of the process no Loader appeared. All my apps and Cydia that installed before was intact. I did install SBsetting, Theme and Icon from Cydia after JB with GP, everything working fine included apps as well. The only problem I face is, 'Size Mismatch' error whichever trying to install OpenSSH. Please don't ask me to restore because I already did.

Thank you in advance and hope u can help.

(19 Feb '11, 17:53) cvliew cvliew's gravatar image

If you open SBSettings>More>Mobile Substrate Addons are any of the entries turned off? That's the only thing I can think of. I would say check a few things by SSH'ing into your phone, but I guess you can't do that. ;)

(19 Feb '11, 18:12) spockers ♦♦ spockers's gravatar image

I turned it OFF/ON it still gaves me the same error. I did everything in SBSetting at the end i still have the same issue.

Thank you.

(20 Feb '11, 03:48) cvliew cvliew's gravatar image

Are you still getting 'size mismatch' error when trying to install openSSH?, what do you want to do with the app, coz you can use a usb based app like Diskaid to gain access to the filesystem, or iFile on the idevice itself.

(20 Feb '11, 03:53) venusanann venusanann's gravatar image

download OpenSSH from your computer and copy it to your device using http://www.macroplant.com/iphoneexplorer/ (this way System/var/root/Media/Cydia/ AutoInstall)

link

answered 20 Feb '11, 05:28

raviraj%20jailbreak%20guru's gravatar image

raviraj jailbreak guru
17.3k181930

Thanks guys for your help, since it failed to install the openssh via cydia, i will dowmload it from computer and copy it to my device. Again, thank you very much for the help and i really appreciate it.

(20 Feb '11, 12:43) cvliew cvliew's gravatar image

Reinstall the source and reboot your device...install it and everything should go perfect... add a slash at the end of the repo so it wont say size mismatch..

link

answered 20 Feb '11, 14:15

TheStraightMusic's gravatar image

TheStraightMusic
111123

Lol it's a community source, Telesphoreo Tangelo from Saurik himself.

(20 Feb '11, 14:30) venusanann venusanann's gravatar image

i use ifunbox to transfer (or ssh if its install) i also recommend d/l terminal.

alot of the time you can go: apt-get install -fix or something (research it) and it will work itself out =

link

answered 20 Feb '11, 14:35

blue%20skies's gravatar image

blue skies
(suspended)

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 19 Feb '11, 05:42

Seen: 2,978 times

Last updated: 20 Feb '11, 14:35

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.