Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

iPhone 4 4.2.1 (from the factory) locked to at&t 03.10.01

I jailbroke using greenpois0n and trying to use FaceTime. It says, "waiting for activation". I tried using "Facetime Hacktivator" from Cydia, but still it's not working.

Is there any workaround? Thanks!

asked 18 Feb '11, 10:10

crabbie's gravatar image

crabbie
(suspended)

Did you actually try that last comment I added at the bottom of my post? Could help without doing a restore. :) I was on the restore verge and it saved me some pain and heartache :)

(18 Feb '11, 11:50) JJMAN JJMAN's gravatar image

Here is a "possible" fix. I have used it for a similar issue and it totally fixed my issue. But please read the whole thing and do exactly as it says and you should be fine. Again this may or may not fix it and I found this on another site awhile back and it DID fix mine as well as several other people on the site I got this info from.

http://www.jjman.org/modules/news/article.php?storyid=58

Good Luck!

JJMAN

link

answered 18 Feb '11, 10:16

JJMAN's gravatar image

JJMAN
1.5k9419

Doesn't work. Tried just now.

(18 Feb '11, 10:39) crabbie crabbie's gravatar image

Ahh try now. the image wasnt linked properly on what lines you need to remove. It may correct your issues with facetime

(18 Feb '11, 10:49) JJMAN JJMAN's gravatar image

"com.apple.imagent.plist" that controls Facetime app.

the file is located in : System/Library/LaunchDaemons

Open in iFile.

Remove lines

<key>DYLD_INSERT_LIBRARIES>/key> <string>/Library/MobileSubstrate/MobileSubstrate.dylib</string>

Save and reboot iPhone.

God Luck :)

JJMAN

(18 Feb '11, 11:00) JJMAN JJMAN's gravatar image

I know that your method might have worked for many, but it's not working for me. Just fyi, I'm running on 4.2.1 and check the following links:

Before editing the file : http://pastebin.com/grFXsuyK After editing the file : http://pastebin.com/Z63zCSqZ

Let me know if I'm doing anything wrong.

Facetime was OFF when I edited this file. Then I rebooted, and switched it ON. It's stuck on Waiting for activation...

Also, check the forum link http://www.sinfuliphone.com/showthread.php?t=46779 It's not working for many people :/

Is your iPhone unlocked? (Which bb? Just for my reference)

(18 Feb '11, 12:18) crabbie crabbie's gravatar image

Yeah I wasn't sure if it would fix your issue or not. I almost didnt type it out because I wasn't sure if people would be afraid of editing there files and such. Rightfully so and all for people to be nervous on editing any file when there starting out. I was just hopeing you did try it and even more hoping it did fix er up for you. Didnt know how savy ya was on this and what all you tried. But I still find stuff to search on here for people and I dont find answers and dont post anything. Thought this one "might" help someone though :)

(18 Feb '11, 13:04) JJMAN JJMAN's gravatar image

Im running iPhone 4 4.2.1 it is NOT unlocked. and its bb is 02.10.04 The next update I will preserve the bb and unlock just so I know how to do it :)

(18 Feb '11, 13:04) JJMAN JJMAN's gravatar image

Do you activate with/use original carrier sim?

link

answered 18 Feb '11, 10:28

venusanann's gravatar image

venusanann
13.3k11618

edited 18 Feb '11, 10:28

As of now, AT&T's sim is inside.

(18 Feb '11, 10:43) crabbie crabbie's gravatar image

As far as I'm aware, if the sim is activated i.e. 'live' then it should activate for facetime, have you left it trying to activate for sometime? I'm not sure why you'd need hacktivation if everything is original carrier.

(18 Feb '11, 11:14) venusanann venusanann's gravatar image

Friend bought it in BestBuy, sent it to India (sealed). I don't think it's activated.

(18 Feb '11, 12:31) crabbie crabbie's gravatar image

I had the same problem I had to restore and rejailbreak next time activate FaceTime before you jailbreak

link

answered 18 Feb '11, 10:49

Rapterf2's gravatar image

Rapterf2
365348

Huh? Can't afford to restore now :( Have installed so many apps.

(18 Feb '11, 10:50) crabbie crabbie's gravatar image

I feel your pain I had to do the same thing it does suck but if you really want FaceTime it's the only option

(18 Feb '11, 11:37) Rapterf2 Rapterf2's gravatar image
-1

Is the iPhone able to make calls? (i.e. Is it unlocked or working on the original carrier?)

I ask this because it sounds like the iPhone is in India and was originally bought from AT&T. If this is the case and the iPhone is not unlocked, then unfortunately facetime would not be able to work :(

You need a valid phone number plus be able to receive SMS on the phone to be able to activate it (facetime gets activated by receiving an SMS)

If the phone DOES make and receive calls you could give MiTime a try

Hope this helps!

Edit: The phone might be required to actually send an SMS to a US number to activate (not sure about this)

link

answered 18 Feb '11, 14:04

mdelaossa's gravatar image

mdelaossa
321139

edited 18 Feb '11, 14:06

Heard of the word, "workaround"? It means NOT going the usual way. Also, how can I make calls if it's locked? Did you even read what I wrote?

(19 Feb '11, 00:19) crabbie crabbie's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×92

Asked: 18 Feb '11, 10:10

Seen: 4,511 times

Last updated: 19 Feb '11, 00:19

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.