Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.x is released, still early stage, mostly for developers - see Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

When i was downgrading my iphone 3gs(modem firmware 05.16.08) using redsn0w 0.9.15b3, a black screen appeared on my iphone screen saying: Error! you must clean poweroff your iphone and try again, but i made a hard reset and my phone entered recovery mode which i cannot get out from. What should i do?

asked 05 Feb '13, 15:51

vawte's gravatar image

vawte
51618


Hard reset out of recovery mode and restore your device in dfu mode. So as soon as it restarts you must start the dfu countdown else it will just go back into recovery. Hold the Power button for 3 seconds Hold the Home button without releasing the Power button for 10 seconds Release the Power Button but keep holding the Home button Keep holding the Home button until you are alerted by iTunes saying that it has detected a device in Recovery Mode

link

answered 05 Feb '13, 15:57

Darknlight55's gravatar image

Darknlight55
2977

edited 05 Feb '13, 15:59

I did the hard reset and as quickly as possible, but it still redirects me to the recovery mode screen on the iphone(usb cable and itunes logo). As you said, the itunes displays a message that my iphone entered recovery mode, i tried to restore it but a message appears saying error (21). What should i do?

(05 Feb '13, 16:36) vawte vawte's gravatar image
1

Slight error in my instructions for dfu mode from recovery mode. If you can't get it to turn off then do this. Hard reset by pressing and holding the home and power button until restart. As it restarts Hold the Home button without releasing the Power button for 10 seconds Release the Power Button but keep holding the Home button Keep holding the Home button until you are alerted by iTunes saying that it has detected a device in Recovery Mode

(05 Feb '13, 16:42) Darknlight55 Darknlight55's gravatar image

It's a little tricky but if you keep trying you will get it.

(05 Feb '13, 16:44) Darknlight55 Darknlight55's gravatar image

okay this worked now. It is in DFU mode. what should i do next? Should i use the tinyumbrella and press the Exit Recovery button? And in the advance settings of tinyumbrella, should i uncheck the button: Request SHSH from cydia?

(05 Feb '13, 16:48) vawte vawte's gravatar image

You can try tiny umbrella to get out of the recovery if that works great. If not then you need to renter dfu more then open iTunes and click recover.

(05 Feb '13, 16:55) Darknlight55 Darknlight55's gravatar image

Or you can try to grab the shsh blobs and continue your downgrade but I'm not sure what state your in atm.

(05 Feb '13, 16:57) Darknlight55 Darknlight55's gravatar image

I pressed the restore button on itunes and now it's verifying iphone restore with apple, but it's taking a lot of time

(05 Feb '13, 17:01) vawte vawte's gravatar image

Oh they displayed a message on itunes saying error 1602

(05 Feb '13, 17:03) vawte vawte's gravatar image

And now it's stuck in DFU mode

(05 Feb '13, 17:03) vawte vawte's gravatar image

You need to clean the host file. Because you we're downgrading it is looking at a custom server Sauriks server likely.

(05 Feb '13, 17:04) Darknlight55 Darknlight55's gravatar image

How do i clean the host file?

(05 Feb '13, 17:07) vawte vawte's gravatar image
1

Windows:

Close iTunes Start –> Programs –> Accessories Run Notepad or WordPad (as administrator on windows 7) Click “Open..” from File menu. Browse to Windows/System32/drivers/etc In "files of type:" select all documents Open "hosts" Either delete all line that has "gs.apple.com", or add a "#" sign at the beginning of the line to comment it out Hit Save Reboot computer for changes to take effect. Visit http://gs.apple.com/ to verify that the hosts file is pointing to Apple and not Cydia. Restore your device.

(05 Feb '13, 17:09) Darknlight55 Darknlight55's gravatar image

Btw. following these steps will restore your device to the latest version. Not downgrading.

(05 Feb '13, 17:10) Darknlight55 Darknlight55's gravatar image

Okay it worked and my iphone is restored. Now, i will use sn0wbreeze to hacktivate my iphone since it isn't factory unlocked. After that, what should i do again to downgrade my baseband? Do I follow these steps again: use redsn0w 0.9.15b3 if you have a " 3GS "

enter DFU Mode.

load redsn0w " specify the 6.0 ipsw " if on 6.0.1 or 6.1.

hit jailbreak

" only " select " downgrade baseband " and DE-select " cydia "

hit next.

Sometimes the downgrade and take two or three times to work. after you downgrade check the modem firmware. you should have 05.13.. if not try again.

(05 Feb '13, 17:40) vawte vawte's gravatar image

Honestly I don't own I iPhone. Only have a iPad 1 & 3 so I wouldn't know the next steps you should take as I've never needed to downgrade the baseband.

(05 Feb '13, 17:52) Darknlight55 Darknlight55's gravatar image

A new problem has arose, when i want to restore my iphone to the custom ios that i made using sn0breeze, 1600 and 1601 errors appear though i used pwned dfu and deactivated my antivirus. What should i do?

(05 Feb '13, 19:22) vawte vawte's gravatar image
1

How do I fix iTunes error 160x when using custom firmware?: http://www.jailbreakqa.com/questions/32462/frequently-asked-questions/33272

(05 Feb '13, 19:31) Darknlight55 Darknlight55's gravatar image

Can also try: open cmd in administrator and type in the console: ipconfig/ flushdns

Then reboot.

(05 Feb '13, 19:35) Darknlight55 Darknlight55's gravatar image

DFU + restore

link

answered 05 Feb '13, 15:54

Mark%20Hack's gravatar image

Mark Hack ♦
27.0k15513

you should get out of it with tinyumbrella!

link

answered 05 Feb '13, 15:54

Filippobr8's gravatar image

Filippobr8
493110

It is still stuck, i used tinyumbrella

(05 Feb '13, 16:13) vawte vawte's gravatar image

When it happened to me I simply rebooted my pc and then i did a clean restore with stock ios. Then i restored againg from pwnd DFU mode using snowbreeze and now it is jailbroken and working like a charm

(06 Feb '13, 06:00) Filippobr8 Filippobr8's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 05 Feb '13, 15:51

Seen: 712 times

Last updated: 06 Feb '13, 06:00

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.