Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.0-8.1 is released (instructions) - see /r/jailbreak on Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

I jailbroke 6.1 successfully yesterday. Today I tried to install Siri on my iPhone 4 but then learned it's piracy. I did a software restore from the backup I made immediately prior to the Siri Installation. It looked as if it was successful, but froze at the apple screen at bootup after the restore completed.

I tried to boot into safe mode with no luck. I was unable to restore again.

I rebooted (it took a hard boot) and now, the only thing I am able to do is go into DFU mode. The phone is not detected in iTunes, however.

Am I hosed, or is there anything else I can do to try to recover this?

asked 05 Feb '13, 15:15

HyperPete's gravatar image

HyperPete
1226

Restore from iTunes backup is NOT a full restore. Open iTunes, place device in dfu and click the restore button.

(07 Feb '13, 11:02) justinred ♦ justinred's gravatar image

I tried that too, and when I had the problem it did not work either. But the problem was resolved 2 days ago.

(07 Feb '13, 15:16) HyperPete HyperPete's gravatar image

Try some simple steps such as restarting your computer and placing your device in DFU mode again. Plug it in and run redsn0w to see if it recognizes the DFU mode. If it does recognize it try reinstalling iTunes.

link

answered 05 Feb '13, 15:19

reV17's gravatar image

reV17
3.7k12820

I'm giving this a shot now.

(05 Feb '13, 15:27) HyperPete HyperPete's gravatar image

No joy. I got "Unable to contact iTunes service update server." After this, no detection by iTunes.

I am behind a firewall at work. I will retry this from home in an hour.

(05 Feb '13, 15:37) HyperPete HyperPete's gravatar image

Redsn0w sees it, yay! Attempting a failed restore recovery.

(05 Feb '13, 15:48) HyperPete HyperPete's gravatar image

Problem with SHSH Blobs.

(05 Feb '13, 15:49) HyperPete HyperPete's gravatar image

basicly this is a bug with i phone 4/4s, its caused mainly through siri but is will be fixed soon :) if you hard boot it off by holding both the power and home button until it turns off and reconnect to your computer it will connect. If your out and about you will have to put it into dfu mode and then tap the home button once and it will boot up :) report this bug to the leaders and help fix it!

link

answered 05 Feb '13, 15:40

DigiTeh's gravatar image

DigiTeh
1624

OK, I left it at the "Apple" for my drive home, and iTunes detected it. I attempted another restore but the restore failed (Unable to restore.) I cold booted and connected and it again detected,also in iFunBox. I saw another thread that showed a file to edit via iFunBox. I am going to try to find it and try that since I cannot restore my backup. If I do I will post it to this thread.

At least there's hope... I don't believe I am hosed just yet!

(05 Feb '13, 16:58) HyperPete HyperPete's gravatar image

i cant find com.apple.SpringBoard.plist anyways pod2g ?@pod2g @GingerKie for the Weather bug, a package in Cydia will be updated, for the long boot, the untether package will be updated.

(05 Feb '13, 17:10) audiogasm audiogasm's gravatar image

I have nothing in that folder. I guess I will try a Restore from Apple to try to get the phone back to defaults. if THAT does not work I am lost... not sure what to try next.

Also, the phone DOES connect, but after 5 minutes it disconnects again. Not sure why...

(05 Feb '13, 17:19) HyperPete HyperPete's gravatar image

EXACTLY same thing im now doing a restore from jailbreakmatrix which doesnt require connectiion to apple server. hopefully i can later do another restore to get my stuff back il post here if it works

(05 Feb '13, 17:21) audiogasm audiogasm's gravatar image

The phone could not be restored. An unknown error occurred. (3194)

OK, who has any ideas from here?

(05 Feb '13, 17:23) HyperPete HyperPete's gravatar image

Consider googling for that error.

(05 Feb '13, 17:26) comex ♦ comex's gravatar image

There's a "more info" link - it references the following:

"If you have installed software to perform unauthorized modifications to your iOS device, that software may have redirected connections to the update server (gs.apple.com) within the Hosts file. You may receive an error 1004, 1013, 3194, or "This device is not eligible for the requested build" in this circumstance. First, uninstall the unauthorized modification software. Then follow the steps to edit the Hosts file and allow iTunes to communicate with the update server in the Blocked by configuration (Mac OS X / Windows) > Rebuild network information > The hosts file may also be blocking the iTunes Store section of iTunes: Advanced iTunes Store troubleshooting."

No HOSTS mods on the computer...

(05 Feb '13, 17:41) HyperPete HyperPete's gravatar image

how old is ur latest backup Pete?

(05 Feb '13, 17:41) audiogasm audiogasm's gravatar image

This morning.

(05 Feb '13, 18:07) HyperPete HyperPete's gravatar image

Holy moly! I just completed the process in the link I posted above - I searched for the file and found it. IT WORKED! WOO-HOO!

My sincere thanks to everyone here who attempted to help me, and also to didiasku!!

(05 Feb '13, 18:26) HyperPete HyperPete's gravatar image

Did you manage to restore or delete siri files and boot normaly?

(05 Feb '13, 18:27) audiogasm audiogasm's gravatar image

I did not need to restore after this. I did remove the siri folders through iFunBot, and after rebooting I went into Cydia and uninstalled the Siri Package. I have rebooted several times now with no problems. - The full name of the file I found and edited is System_Library_LaunchDaemons_com.apple.SpringBoard.plist - Use the search in iFunBox and once you find the file, abort the search. Then copy the file to your computer and edit it as explained in the other thread. Save the file and copy it back to the folder it's from (Right-click the file you found, open containing folder.) - Let me know if that works for you or if I can be of any help...

(05 Feb '13, 18:53) HyperPete HyperPete's gravatar image

Shame i did a 3 months old restore because i couldnt find that file to edit Also shame that mods close these threads. We are not asking to get a pirate app working, we just want to get our phone to work

(06 Feb '13, 11:18) audiogasm audiogasm's gravatar image

Sorry you were unable to find the file. At least your phone isn't bricked! I concur - the issue with piracy is being overdone a bit. But they just want a very clear line drawn so there is no misunderstanding, I'm sure. And there should be an evasi0n update soon that resolves the issues. There are enough threads about the topic that even if a thread is closed, someone should be able to locate the information they need to fix their devices. Cheers my friend!

(06 Feb '13, 14:23) HyperPete HyperPete's gravatar image

sounds to me like your screwed. if it was not detected by itunes even in DFU mode. thats a problem

link

answered 05 Feb '13, 15:18

jb2013's gravatar image

jb2013
31811

Restore in itunes the whole thing

link

answered 05 Feb '13, 15:20

Jasonv4sios5-0-1's gravatar image

Jasonv4sios5-0-1
-73411

That's what caused the problem. I ran a full restore, and apparently it failed. Phone did not restart after restore and now does not detect in iTunes (or iFunbox)

(05 Feb '13, 15:23) HyperPete HyperPete's gravatar image

Well ive never know an iphone to fail after failed restore i suppose youve tried to hard reset for 20 SECS! If not use a exit recovery mode tool ie redsnow sounds like your only hope!

(05 Feb '13, 15:29) Jasonv4sios5-0-1 Jasonv4sios5-0-1's gravatar image

Yes, I've hard reset. I don't know if it was fully 20 seconds, so I will try that again. I have to head out for about an hour in 20 minutes but I will return after that to continue troubleshooting. Thank you for your help

(05 Feb '13, 15:36) HyperPete HyperPete's gravatar image

No worries pal good Luck

(05 Feb '13, 15:59) Jasonv4sios5-0-1 Jasonv4sios5-0-1's gravatar image

same phone and problem damn the russians... logo goes away every few min then returns. trying hard reset is even harder when you have fauly home button i guess this is karma for piracy

link

answered 05 Feb '13, 15:53

audiogasm's gravatar image

audiogasm
15116

edited 05 Feb '13, 16:04

Did you get it resolved?

(06 Feb '13, 08:16) HyperPete HyperPete's gravatar image

Need help skipping the bug? problems? Skype me

link

answered 05 Feb '13, 17:01

DigiTeh's gravatar image

DigiTeh
1624

I don't have Skype. Why not share your knowledge here where it will help many others?

(05 Feb '13, 17:42) HyperPete HyperPete's gravatar image

I found the thread: http://www.jailbreakqa.com/questions/142469/iphone-4-doesnt-start

Wish me luck!!!

link

answered 05 Feb '13, 17:06

HyperPete's gravatar image

HyperPete
1226

Here's the answer from that thread:

i was able to work around this brick. plug your phone into your computer and start up ifunbox, once it connects, go to the /System/Library/LaunchDaemons folder. open the com.apple.SpringBoard.plist in wordpad, remove the following

<key>EnvironmentVariables</key> <dict> <key>DYLD_SHARED_CACHE_DIR</key> <string>/var/siriport.ru/Cache4S</string> <key>DYLD_SHARED_CACHE_DONT_VALIDATE</key> <string>1</string> <key>DYLD_SHARED_REGION</key> <string>private</string> </dict>

then go to the root folder of your phone in ifunbox, do a search for siri, delete the files/folders that are associated with siri.ru, etc. this should be somewhat obvious unless you have siriusxm installed (i do and it still wasnt too hard). then do a hard reset and you should be back up and working

(05 Feb '13, 18:38) HyperPete HyperPete's gravatar image

I had the same problem after installing Winterboard. I put the phone in DFU mode and ran redsn0w. I clicked the "Extras" button. I then clicked the "Recovery Fix" button and all fixed!

link

answered 07 Feb '13, 10:56

MatBishop3000's gravatar image

MatBishop3000
263

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,492
×236
×154
×5

Asked: 05 Feb '13, 15:15

Seen: 2,409 times

Last updated: 07 Feb '13, 15:16

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.