Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

6
2

Ever since I jailbroke, my iCloud Tab syncing is not working anymore. Trying to see if others are experiencing the same issue. These are the steps I tried:

• Closed all tabs on iPad and iPhone

• Turned off Safari syncing in iCloud Settings panel, chose to delete data from devices

• Force-quit Safari with no tabs open and Safari sync turned off

• Turned back on Safari sync in iCloud Settings panel

• launched Safari and saw if iCloud tabs work properly

What I found is while Reading list and bookmarks restore properly, iCloud tabs on all devices still show the last set of tabs before the jailbreak. Can other people confirm this? Is there a place to submit bugs to the jailbreak team?

After the latest update on Cydia, iCloud syncing is working for me on my iPhone 4s (GSM). It is still not working on an iPad 2 (GSM). Please when reporting your specific details, mention what kind of hardware you have issues with (what model iPhone/iPad/iPod Touch, and whether GSM or CDMA). Thank you!

The problem was still apparent for me on the iPad 2, so I followed the steps @to86 outlined (deleting the two cache files). This is now working for me across devices, but there is a phantom iPad left over from earlier. I will post back in a week if the device disappears.

UPDATE Feb 10: I can confirm that eventually the phantom device disappeared. I no longer have the iPad showing up twice. Whether this is related to one of the subsequent updates, or just a time out, I don't know, but iCloud Tab Syncing is working once again...

asked 05 Feb '13, 14:14

jbthemofo's gravatar image

jbthemofo
1.4k7215

closed 14 Aug '13, 21:36

spockers's gravatar image

spockers ♦
57.9k327849

1

Me confirm this problem, any solution?

(05 Feb '13, 18:04) Estebanschafer Estebanschafer's gravatar image

I am having the same issue. I hope they pick this up, because I use icloud tabs a lot. Anyone know of a fix? is this is a known issue?

(05 Feb '13, 19:56) to86 to86's gravatar image

same here :( the reading list and bookmarks bar are ok. they sync. but not the tabs.

(05 Feb '13, 20:07) cheled cheled's gravatar image

If enough people post here hopefully they will come up with a fix. Would be useful to know what tweaks everyone has to see if there is a tweak that might be causing a conflicts? I have flex, unrestrictpremium, bulletin, ncsettings, ifile and fullforce

(05 Feb '13, 20:11) to86 to86's gravatar image

i have bitesms, intelliscreen x, kill background, double@, quick reply for whatsapp. thats it. nothing you have :(

(05 Feb '13, 20:14) cheled cheled's gravatar image

I have tried to disable ALL tweaks. I booted up in safe mode, I tried to disable the tweaks via the Mobile Substrate disabling in SBSettings. Then I tried to delete all the jailbreak tweaks including SBSettings. This is with the base jailbreak/Cydia. You need not have ANY tweaks for this problem to appear. I guess very few of us use the iCloud Sync feature - I would have thought more people would be mentioning this.

(05 Feb '13, 20:15) jbthemofo jbthemofo's gravatar image

I can confirm that iCloud documents is still working for me, so looks like it is just iCloud tabs. How frustrating!

(05 Feb '13, 20:15) to86 to86's gravatar image

Yes, as has been mentioned, this does not affect any other part of iCloud, nor does it affect Reading List nor Bookmark syncing. This is JUST an issue with Tabs in the Cloud.

(05 Feb '13, 20:17) jbthemofo jbthemofo's gravatar image
1

there is a thread on macrumors, so it isn't just us: http://forums.macrumors.com/showthread.php?t=1537619&page=2

(05 Feb '13, 20:20) to86 to86's gravatar image

I've jailbroken twice on a 4S and an iPad 2 over the past year and immediately after each time I did, every part of iCloud (except backing up) has ceased to work. No tab syncing, no contact syncing, calenders, notes, etc... I'm curious as to why jailbreaking would stop syncing between my devices and my iMac.

(06 Feb '13, 03:30) irespectfemales irespectfemales's gravatar image
1

I would let the devs know via twitter as well

(06 Feb '13, 05:21) to86 to86's gravatar image

It looks like it has been fixed with the evasi0n update!! :-)

(06 Feb '13, 13:46) to86 to86's gravatar image

same thing here, now that i think about it, this also happened last time on 5.x jailbreak as well, it was unresolved until I upgrade to 6.0 and lost the jailbreak

(06 Feb '13, 13:51) softboysxp softboysxp's gravatar image

It is now working for my iPhone, but still not for the iPad, I'm using PhoneView to navigate around and look at the com.apple.mobilesafari.plist file to try and diagnose, but so far no go...

My Mac Pro, MacBook Pro, and iPhone still show the old tabs in the iPad, and the iPad still shows tabs that have not been on the other devices in days.

(06 Feb '13, 14:02) jbthemofo jbthemofo's gravatar image

I have the same issue. My iPhone 4 and iPad 3 (both on iOS 6.1) don't sync tabs between devices since I've applied the jailbreak. I've applied the latest evasi0n patch from Cydia but it's still occurring. I also have tried the suggestion in the MacRumors thread of toggling Safari iCloud sync off and on but that doesn't help.

For those of you affected, did you disable any launch daemons? I have about 20 or so disabled on each device; none that I though were iCloud related, but I could be wrong.

(06 Feb '13, 14:19) ahplk ahplk's gravatar image

Alright, so the latest evasi0n fixed it for my iPhone, but not for the iPad. The iPad is still showing outdated info for all devices, and they still show outdated info for the iPad.

I tried deleting the com.apple.mobilesafari.plist file located at /User/Library/SyncedPreferences, but I just ended up with a blank iCloud Tabs on the iPad. I also tried turning off and on iCloud tab syncing on the iPad multiple times. My next step is to turn off iPad Tab syncing and leave it off for a week, for the iCloud Tabs time out, and then turn it back on, but so far, it appears to still be broken on the iPad. Since it is fixed on the iPhone, I am unsure if it is related to the Jailbreak or to the iPad, but I did not have this problem before the Jailbreak.

I will post this also as another answer...

(06 Feb '13, 14:31) jbthemofo jbthemofo's gravatar image

Could you try and apply the latest updates through Cydia and see if it is fixed for the iPhone and not the iPad? For me and for someone else in this thread, the latest updates via Cydia fixed it for our iPhones, but not our iPads.

(06 Feb '13, 15:07) jbthemofo jbthemofo's gravatar image

Did you just have an iPhone, or an iPhone and an iPad, or an iPad? It seems as if this may have been fixed for iPhones, but not iPads.

(06 Feb '13, 15:08) jbthemofo jbthemofo's gravatar image

As I stated in my previous comment, I've applied the latest evasi0n patches (released this morning) on Cydia. Neither device is fixed as both are showing pre-jailbreak tabs.

(06 Feb '13, 15:12) ahplk ahplk's gravatar image

and @to86, can you tell us what kind of iPhone it is working with?

(06 Feb '13, 15:27) jbthemofo jbthemofo's gravatar image

Thanks @ahplk. I see you have an iPhone 4 — I have a 4s. I just asked the other person who has it working on their iPhone what iPhone they have. Let's see if it is isolated to specific devices.

(06 Feb '13, 15:28) jbthemofo jbthemofo's gravatar image

Here's another thought...

Are you using an ad blocking hosts file? Perhaps an Apple server was mistakenly added somewhere down the line? I'll try disabling mine to see if that fixes it.

(06 Feb '13, 15:29) ahplk ahplk's gravatar image

No, I am using no such file. Can you confirm yours is an iPhone 4 and not 4s?

(06 Feb '13, 15:34) jbthemofo jbthemofo's gravatar image
1

That was a different issue related to iCloud syncing overall. iOS 5 did not support Tabs in the cloud. As mentioned here:

http://support.apple.com/kb/HT5372

Keep in mind that while iCloud Tabs is only available for Macs with OS X Mountain Lion installed, and devices with iOS 6, you can still use normal iCloud Bookmarks to sync saved Bookmarks and Reading List content between any devices that meet the iCloud system requirements. Bookmarks sync is not the same as iCloud Tabs synchronization, but it will allow you to move Bookmarks content between devices.

(06 Feb '13, 15:37) jbthemofo jbthemofo's gravatar image

Yes, it's an iPhone 4 (GSM) and an iPad 3 (Wifi) both on 6.1 and all patched up from Cydia as of this post. I did a fresh restore on both of them prior to the Jailbreak.

I just tested my hosts file theory and that's not it.

(06 Feb '13, 15:41) ahplk ahplk's gravatar image
1

iPhone 4S and Ipad 3rd Gen with 6.1 Please see my post below, outlining the steps I took.

(06 Feb '13, 15:41) to86 to86's gravatar image

They are unrelated. See here:

http://support.apple.com/kb/HT5372

Keep in mind that while iCloud Tabs is only available for Macs with OS X Mountain Lion installed, and devices with iOS 6, you can still use normal iCloud Bookmarks to sync saved Bookmarks and Reading List content between any devices that meet the iCloud system requirements. Bookmarks sync is not the same as iCloud Tabs synchronization, but it will allow you to move Bookmarks content between devices.

(06 Feb '13, 15:47) jbthemofo jbthemofo's gravatar image

you're right, must've confused it something else, maybe 6.0 betas, :P

(06 Feb '13, 15:54) softboysxp softboysxp's gravatar image

Thanks. Please vote up my comment :)

(06 Feb '13, 16:10) jbthemofo jbthemofo's gravatar image

Thanks. Your steps fixed this for me, although I have a phantom iPad still there. Hopefully it will be gone in 7 days (as per Apple's tech note)

(06 Feb '13, 16:11) jbthemofo jbthemofo's gravatar image
1

Looks like this can be fixed by deleting the cache files. Only caveat is you MAY end up with a phantom device. It should fall off the tabs in a week.

(06 Feb '13, 16:14) jbthemofo jbthemofo's gravatar image

Well, I've tried just about everything. Re-enabled launch daemons, reset hosts file, cleared caches, hard reboots, resprings, toggled iCloud, updated with fixes from Cydia, disable all tweaks on boot...I'll just have to live with it.

(06 Feb '13, 16:15) ahplk ahplk's gravatar image

The comment, not the initial question. See the finger up to the right. Trying to draw people's attention to the Apple support doc.

(06 Feb '13, 16:18) jbthemofo jbthemofo's gravatar image
1

yup actually did both, too many thumb ups, lol

(06 Feb '13, 16:19) softboysxp softboysxp's gravatar image

Thank you! Yeah, I noticed I got a thumbs up on the question, and assumed you thought I meant that — but the question was not what I was referring to, although the question MAY help people find the answer that @to86 gave, which solved it for me (with the caveat I mention)

(06 Feb '13, 16:22) jbthemofo jbthemofo's gravatar image

Bah, it's fixed for me now. I had to re-enable all my launch daemons and delete the cache files on both of my devices. For some reason, my initial test with replacing the launch daemons didn't copy all of them over. I've yet to figure out which daemon is the culprit.

(06 Feb '13, 16:45) ahplk ahplk's gravatar image

Went through disabling launch daemons again and couldn't recreate the issue...odd.

(06 Feb '13, 17:23) ahplk ahplk's gravatar image

The issues last year with iCloud and iOS 5 were unrelated to iOS 6 and Tab Syncing. The initial jailbreak only seem to have caused problems with Tab syncing, and as far as I can tell, it ay have only been for a subset of us.

(07 Feb '13, 14:01) jbthemofo jbthemofo's gravatar image

I can confirm that eventually the phantom device disappeared. I no longer have the iPad showing up twice. Whether this is related to one of the subsequent updates, or just a time out, I don't know, but iCloud Tab Syncing is working once again...

(10 Feb '13, 20:14) jbthemofo jbthemofo's gravatar image

Can you explain what a "Phantom device" is exactly? I'm having problems with my iCloud tabs now on both my iPhone 5, 6.1 Evasi0n and MacBook Pro retina, only if I respring my iPhone does it show some tabs but only on the iPhone and the tabs are from my MBP retina over a week ago and not open on it anymore. Very strange. Thanks

(09 Apr '13, 20:09) 1080pete 1080pete's gravatar image

That is what I meant by Phantom tabs - tabs from a device that is no longer there. After the steps outlined here and the evasi0n updates and a week of letting the tabs time out, the tabs went away.

(09 Apr '13, 20:11) jbthemofo jbthemofo's gravatar image

The question has been closed for being "Solved" by spockers, 14 Aug '13, 21:36


Mine seemed to fix with the update plus 1 or 2 extra steps, let me outline the steps for everyone, hopefully it works. I have an iphone 4S and iPad 3rd gen, both running iOS 6.1. The iphone started syncing immediately following installation of the new evasion update, following reboot. My iPad did not work and I tried the extra steps.

1) Install evasion update and make sure you reboot 2) Uninstall appsync if you have it installed 3) If still not working use iFile or other file explorer to navigate to var/mobile/Library/caches and delete the following two files: com.apple.mobile.installation.plist com.apple.LaunchServices-045.csstore 4) reboot again. Your apps will be missing, but dont be alarmed, they come back automatically over the first minute or so.

This fixed the issue for me. Hopefully it worked for you.

link

answered 06 Feb '13, 15:40

to86's gravatar image

to86
131135

edited 06 Feb '13, 15:41

1

Alright, so the latest evasi0n fixed it for my iPhone, but not for the iPad. The iPad is still showing outdated info for all devices, and they still show outdated info for the iPad.

I fixed it for the iPad by following the steps @to86 outlined and deleting the two cache files he talks about. Please see his post for their names and vote up his answer!

(06 Feb '13, 14:32) jbthemofo jbthemofo's gravatar image

same thing here. Evasi0n update fixed iPhone but not iPad.

(06 Feb '13, 15:02) softboysxp softboysxp's gravatar image

Now that is VERY curious. Now I am safely assuming that this is not an issue with my specific configuration, nor an isolated thing, but rather a specific bug that was fixed with the iPhone and not the iPad. Thank you for your comment!!!

(06 Feb '13, 15:06) jbthemofo jbthemofo's gravatar image

@softboysxp — what kind of iPhone do you have, and what kind of iPad? Would be nice if we can isolate it to specific hardware. Thank you!

(06 Feb '13, 15:29) jbthemofo jbthemofo's gravatar image

@jbthemofo tested on an iPhone 5 and iPad 3. also I compared jailbreak apps I have on both devices, the tweaks I have on iPad is a strict subset of those on iPhone, so I think it's probably not caused by any tweaks or anything.

(06 Feb '13, 15:33) softboysxp softboysxp's gravatar image
1

@softtboysxp — interesting. So so far the issue seems to be fixed on my iPhone4S, but not fixed on the iPhone 4, iPhone 5, iPad 2. So it is not a core issue (the iPad 2 and the iPhone 4s both have the A5). Let's see if more people shed more light on what may be the specific devices. Still trying to see if the people who now have it working have an iPhone4S.

(06 Feb '13, 15:44) jbthemofo jbthemofo's gravatar image

Didn't work for me. Both my iPad and iPhone are still affected after deleting those fles (I've never installed AppSync).

Edit: Fixed for me after re-enabling all launch daemons and clearing those cache files.

(06 Feb '13, 15:53) ahplk ahplk's gravatar image

So this kind of fixed it for me. I now have a phantom iPad still lingering around with outdated information, although my iPad is now properly showing the other machines (and the phantom iPad), and the other machines are showing the iPad (as well as the Phantom iPad). I am hoping it will drop off in a week.

Thank you for your help! We'll see if this solves it for other people.

Note, I used phoneView to delete those files. Also note, I did not have AppSync installed.m I just deleted the two cache files.

Any insight as to how to get rid of the phantom iPad other than waiting a week?

(06 Feb '13, 15:59) jbthemofo jbthemofo's gravatar image

Latest Evasi0n update fixed it for me too, seems to be working fine now. On another note though, Weather app bug is still present.

(07 Feb '13, 09:23) irespectfemales irespectfemales's gravatar image

I have not had the Weather App issue since the evasi0n update through Cydia, and this is fixed other than the phantom iPad that I hope will drop off in a few days. I have an iPhone 3GS, an iPhone 4s, an iPod Touch 4G, and an iPad 2, all running 6.1, and a Mac Pro running 10.8.2 and a MacBook Pro running 10.8.2. All show each other's tabs properly, and all (including the iPad) also showing a phantom iPad 2 from before the JB. As I said, I assume it will drop off after 7 days.

(07 Feb '13, 13:59) jbthemofo jbthemofo's gravatar image

I can confirm that the method described by @to96 and jbthemofo works.

My device is iPad mini and i sync it with my MBA. The problem was still there despite tat i've updated evasi0n via cydia. I used cyberduck to delete the 2 cache files, disabled and enabled icloud-safari on both devices and TabSync work again.

But i've noticed that my ipad safari synedc slower than that of my MBA. Not sure if this is normal and was like that even before the jailbreak. My MBA update the tabs almost immediately, but the ipad takes a few minutes or immediately after a restart (safari).

There is no 'phantom' phenomenon.

No re-launch daemon done.

Hope this fix helps everyone..

(10 Feb '13, 05:40) emfung emfung's gravatar image

started working for me after removing app sync

(10 Feb '13, 14:37) manjer manjer's gravatar image

I never had app sync. I am sure appsync causes all sorts of problems, but people had this problem without appsync. Correlation does not imply causation. There have been a bunch of fixes to the jailbreak since this issue was mentioned, the 1st patch seemed to have fixed it for everyone else. It could be you removed app sync at a similar time to updating the jailbreak itself.

(10 Feb '13, 20:33) jbthemofo jbthemofo's gravatar image

Removed it yesterday just before posting

(11 Feb '13, 05:15) manjer manjer's gravatar image

WORKED, with 1 minor additional step. ( IPad 2 on 6.1, IPhone 4S on 6.1.1.) Deleted the two files mentioned above using iFile. Resprung devices. Then killed Safari on both devices using the task-switcher. Then turned Safari off on the list of iCloud syncing servicing in Settings/ ICloud. When asked, deleted previously saved safari info from both devices. Waited about 10 seconds and turned iCloud safari syncing back on. Boom! Never used this feature before. When you check for a tab open on the iPad in the iphone iCloud tabs folder, it takes a few seconds for the most recently opened ones to populate the list. I assume that's how it works. Pretty handy, and thanks for the info to86!

(16 Feb '13, 08:23) Daveofarbutus Daveofarbutus's gravatar image

Ok. So this fixed my tab syncing problem, but my apps DIDN'T come back after a minute or so. After an hour now they still haven't come back. Any solutions to repopulate my apps?

(27 Mar '13, 01:02) wthorne wthorne's gravatar image

UPDATE: apps never came back even after hours. However, deleting the launch file again forced it to repopulate on the next reboot. Also: fixed weather app crashing.

(28 Mar '13, 07:44) wthorne wthorne's gravatar image

The above method of deleting Appsync which I didn't even realise was on my iPad 2 as I don't pirate games and deleting the 2 cache files solved this problem. Not only was cloud tabs not working but icloud game saves would not work either. Thanks

link

answered 14 Aug '13, 21:32

RidiculocitY's gravatar image

RidiculocitY
111

Use the "add a comment" button unless you are answering the original question. The button looks like this:

(14 Aug '13, 21:35) spockers ♦ spockers's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×138
×119
×82
×10

Asked: 05 Feb '13, 14:14

Seen: 9,786 times

Last updated: 14 Aug '13, 21:36

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.