Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Hi, I have downloaded the correct firmware (6.1) for my iphone 4s which is using version 5.1.1. When I try to update or restore via itunes using the downloaded firmware, I get the following error: The iphone could not be restored. An unknown error occurred (0xE8000004)

If anyone can help with this it will be very appreciated. Many thanks

asked 02 Feb '13, 18:14

gizmo001i's gravatar image

gizmo001i
126125


Stupid, stupid, stupid. Thank you both for you're help. However, it was my stupidity that caused the problem. I forgot that I had installed "recovery guard" on my phone and it was blocking the process.

link

answered 02 Feb '13, 19:27

gizmo001i's gravatar image

gizmo001i
126125

Are you using the latest version of iTunes? Try reinstalling it.

If that doesn't help, what happens if you visit http://gs.apple.com/? If you get a Cydia page, you'll need to fix your hosts file (we can explain how to do that). If you get a normal page, your hosts file is fine.

Also check out this list of solutions for iTunes restore errors.

link

answered 02 Feb '13, 19:02

britta's gravatar image

britta
25.2k115935

Hi, thank you for you're help. When I go to http://gs.apple.com/, I get a GCS Default Web Server which states: the page is just a placeholder etc. I will try reinstalling itunes now.

(02 Feb '13, 19:07) gizmo001i gizmo001i's gravatar image

OK, that placeholder page is normal.

(02 Feb '13, 19:14) britta britta's gravatar image

Thank you, just backing up my itunes folder and then will reinstall itunes. If that doesn't work, would it be worth trying to update in DFU mode?

(02 Feb '13, 19:16) gizmo001i gizmo001i's gravatar image

Just realised, I have recovery guard installed on the phone, going to remove it and try again lol.

(02 Feb '13, 19:19) gizmo001i gizmo001i's gravatar image

Didn't mean to bump this post (God, it's 2 yrs old...) but wanted to update this post as it helped me just now:

I was getting this same error (0xE8000004) trying tonight to upgrade iPhone 5S from 7.0.4 to 8.1.2 (and then use Taig to JB) and kept getting that error.

Now, the hosts file did direct to cydia, so I fixed that (got the default text HOSTS file from Microsoft website), but that didn't help. Then I found out/remembered (thanks to this old post) I also had "NO PLS RECOVERY" tweak installed, and that was blocking my restore to 8.1.2

Dumb on my part yes, but now it's working. Maybe this'll help someone out too.

No need to comment or anything. Just close this and file it away.

link

answered 08 Feb '15, 23:26

Hebbydyr's gravatar image

Hebbydyr
1.4k9618

Just plug it in and hit restore as you normally would the result will be the one you're trying to achieve. And make sure that iTunes is downloading a new .ipsw instead of the one you've been using

link

answered 02 Feb '13, 18:29

gpscar's gravatar image

gpscar
33419

Hi, I've tried that and I get:

There was a problem downloading the software for the iphone. The requested source was not found.

(02 Feb '13, 18:36) gizmo001i gizmo001i's gravatar image

Then your hosts file must be redirecting the DNS request for the download

(02 Feb '13, 18:38) gpscar gpscar's gravatar image

Thanks for you're reply, I must admit, I'm not sure what you mean.

(02 Feb '13, 18:39) gizmo001i gizmo001i's gravatar image

Have you ever run TinyUmbrella or tried downgrading your device?

(02 Feb '13, 18:43) gpscar gpscar's gravatar image

No I haven,t at all. Also when I check for updates in itunes, it states that my ios 5.1.1 is the current version and that no update is available.

(02 Feb '13, 18:45) gizmo001i gizmo001i's gravatar image

What generation is it?

(02 Feb '13, 18:58) gpscar gpscar's gravatar image

It is a 4s, model MD235B, firmware 2.0.12. I have tried different USB slots and different cables as well with the same results. The phone states that there is an update to 6.1 available, but if I understand correctly a jailbroken phone cannot be upgraded unless it is via itunes.

(02 Feb '13, 19:04) gizmo001i gizmo001i's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 02 Feb '13, 18:14

Seen: 4,832 times

Last updated: 08 Feb '15, 23:26

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.