Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Instructions for jailbreaking iOS 8.0-8.1.2. See /r/jailbreak on Reddit, @PanguTeam, and @TaiG_jailbreak for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

Hi there, I thought it is about time to ask the Pros here for some help as I have been hunting on the web for several months including on this forum, but most posts are either too old or irrelevant. I must have spend over 40 hours now trying all sorts of programs (tinyUmbrealla, Redsn0w, Ultrasn0w etc.), scripts, and files (cydia fixers etc.) to try and fix my iPhones and I really can't keep wasting more time.

So here it is: I have 2 iPhones, both are 3GS and both have the NO SERVICE problem, both I have managed to get onto 5.0.1. (One was on 5.1.1 and the other on 6.0.1) They are both from weeks 35+ (serial 869485.... for one of them, 79946 for the other) So they are new Bootrom and from the later production batch. So as I understand from hunting through the web these can't simply be flashed with the Ipad BB or altered using Redsn0w and Cydia tweaks. I have tried all sorts of Jailbreaks, including SSH blob stitched ones, baseband preserved ones. So I am rather stuck as most fixes for the iPhones are for old bootrom/week 35-. What can you guys recommend?

asked 18 Jan '13, 03:04

Seanantasy's gravatar image

Seanantasy
26418

you need year / week, modem firmware ?

(18 Jan '13, 03:05) Mark Hack ♦ Mark%20Hack's gravatar image

Have either of these phones ever had service before? When did this all start? If they are blacklisted (reported lost/stolen or contract broken) then you'll get the results you're seeing.

(08 May '13, 17:50) spockers ♦♦ spockers's gravatar image

You seem to be a bit confused. The first five digits of the serial number mean FFYWW (F=Factory, Y=Year, WW=Week)

The mark for old/new bootroms are xx945 (2009 week 45). The iPhones that can not be flashed with the iPad baseband are xx135+ phones. (2011, week 35+).

If your phones are indeed xx9xx then they are okay to install the iPad baseband on which you will then immediately want to flash again down to 05.13.04

link

answered 18 Jan '13, 03:14

cybr1d's gravatar image

cybr1d ♦
24.9k265738

edited 19 Jan '13, 14:14

JuergenWest's gravatar image

JuergenWest ♦
11.8k352645

after installing the ipad baseband follow the same steps to downgrade them back to 05.13.. and remember if you're on 6.0.1 you'll need to install ultrasn0w and ultrasn0w fixer for it to work.. Reboot the phones if needed..

(18 Jan '13, 04:11) Mark Hack ♦ Mark%20Hack's gravatar image

Aaahh indeed I was confused, so many videos and forums all merged into a blur of text now really. But thanks very much! Will try flashing to iPad bassband now and hope that works.

(18 Jan '13, 18:24) Seanantasy Seanantasy's gravatar image

I hope it works too :) As @markhack said, after installing the ipad baseband, you should re-run redsn0w and downgrade the baseband. It will end on 5.13.04

(18 Jan '13, 18:35) cybr1d ♦ cybr1d's gravatar image

Hi again, thanks for the comments guys. I tried to upgraded the baseband 5.16 to the iPad baseband and first 3x it came up with the error 'exploit failed' in Redsn0w, then it finally went through, but on reboot it hung on the apple logo, so I did soft reset after 15 mins waiting and iPad baseband was installed. I tried sim for laugh and indeed No Service. I then tried to downgrade iPad baseband, again same as above it came up with 'exploit failed' 4x or 5x in redsn0w and then went through on 4/5th try and had to do soft reset as it hung on apple logo again, but 5.13 baseband installed. But I put my sim in and still 'No service' I've turned 3G off and all other network options off and did soft reset, and tried a reset of all network setting in iPhone settings, but still No Service???

(18 Jan '13, 19:37) Seanantasy Seanantasy's gravatar image

If the baseband is 5.13 you need to install Ultrasn0w from Cydia to actually unlock it. (you also need Ultrasn0w Fixer if you're on 6.0.1)

(18 Jan '13, 19:41) cybr1d ♦ cybr1d's gravatar image

Ok I now have an iPhone 3GS on 5.0.1 with baseband 5.13. But it still has 'NO SERVICE' I have installed Ultrasn0w from Cydia (not the fixer) and as suggested by Curly420. But still 'NO SERVICE'. I did a reboot etc. I've continued researching and on some forums they say you need to get the phone onto baseband 5.13 and then upgrade to iOS 6.0 and install Ultrasn0w fixer followed by Ultrasn0w as Curly420 suggests aswell. But I can't because at the moment as soon as I open iTunes and the iPhone is recognised iTunes crashes with an unknown error. Without the iPhone plugged in and on other iPhones it all works fine. So I put the iPhone into DFU and iTunes recognises it normally and I can restore and when trying to restore to 6.0 it generates error 3194 no matter what I do to the hosts file. Any other suggestions?

(19 Jan '13, 12:45) Seanantasy Seanantasy's gravatar image

try up/downgrading it again.. re-installing ultrasn0w and Fixer..

(19 Jan '13, 13:30) Mark Hack ♦ Mark%20Hack's gravatar image

to restore 6.0 or any other ipsw apple no longer signs you'll need SHSH files. Use redsn0w to find what SHSH files the device has. this will let you know what firmwares you can restore to.

(19 Jan '13, 13:31) Mark Hack ♦ Mark%20Hack's gravatar image

Keep in mind after restoring to any given iOS version you will want (need) to activate the device using the original carrier SIM prior to jailbreaking and software unlocking in order to avoid "hacktivation" issues (excessive battery and data drain).

(19 Jan '13, 14:17) JuergenWest ♦ JuergenWest's gravatar image

No I've tried again and to no avail. As Markhack suggested I noticed that only SSHH blobs can be found for some of the older firmwares but I only get No SERVICE no matter what on them or I get error 3194 trying to restore to any of them as apple doesn't sign them anymore, and there are no SSHH for any of the newer iOSes except the latest 6.0.1 so am going to give that a try.

(21 Jan '13, 15:10) Seanantasy Seanantasy's gravatar image

Darn, still NO SERVICE. I installed 6.0.1 using Redsn0w's restore and sshh blobs, NO SERVICE so I jailbreaked and installed Cydia and then first Ultrasn0w fixer and then Ultrasn0w. It then showed the 'Searching' for signal for an hour at least and then, NO SERVICE. I switched off 3G and Roaming etc. and it searched again for a while and then NO SERVICE.

(22 Jan '13, 05:54) Seanantasy Seanantasy's gravatar image

No service mean you not yet unlocked

(22 Jan '13, 19:12) Answers to iPhones Answers%20to%20iPhones's gravatar image

Hi guys,

I'm still trying but now really getting to the stage of giving up. Almost half a year ago now I posted on here about 2 Iphones both the 3GS models and both are models from 2009 weeks 42+. They both have all features working except signal as both display the 'No Service.' I've been working on them for months an hour or so every other evening, trying anything and everything I have come across through a multitude of forums and website but still no luck. Neither of them has any broken parts such as Diodes missing etc. on motherboard and I have tried both motherboards in other 3GS cases with working antennas etc. I have tried all the tricks from downgrading Ipad baseband to using Redsnow restore feature, using Ultrasnow and Ultrasnow Fixer etc. Of course as the months have moved allong so have the IOSes and now the tricks that worked on 5.1.1 and 6.0.1 don't work anymore as SHSH blobs and Itunes-Shift restores don't work anymore. I have tried upgrading one of the iPhones to 6.3.1 hoping this new IOs would solve the problems, but naturally it did nothing and I am still stuck with 'No Service'

Can anyone who has had an iPhone 3GS with 'No Service' post me a reply with a breakdown of their working and tested fix please!!

(08 May '13, 18:14) Seanantasy Seanantasy's gravatar image
1

Have either of these phones ever had service before? When did this all start? If they are blacklisted (reported lost/stolen or contract broken) then you'll get the results you're seeing.

(08 May '13, 18:35) spockers ♦♦ spockers's gravatar image

I'm a school teacher of technical and fix a lot of iphones of my pupils and mates as a hobby, but I got these 2 iphones of eBay a while back, the sellers were selling them as their own phones in working condition but with tatty/scratched screen and back, so I've bought them refurbed back and front in hope to sell on to pupils/mates. But when I got them they had no-service. The previous owners had restored them and I believed they were probably jail broken before they restored them so thought he restore mucked up the jailbroken firmware causing the no-service error. But you may well be right in that they are stolen/blacklisted. How can I check if they are?

(09 May '13, 12:37) Seanantasy Seanantasy's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

Asked: 18 Jan '13, 03:04

Seen: 1,517 times

Last updated: 09 May '13, 12:37

Related questions

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.