Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I have an iPhone 3GS (new bootrom, 4.1, with the iPad BB (I used the unlock while travelling)) So today my iPhone was being really slow and I wanted to restore it, so I put it in DFU mode and tried to restore. I went with a custom 4.2.1 firmware because of the iPad BB. So after I did the Shift+Restore iTunes gave me error an error 1600 and then the second time an error 21 and the iPhone rebooted into recovery mode. Now I can't put it in DFU mode and/or restore with custom firmware. Trying to restore with stock firmware gives me error 1015.

How can I fix this?

This question is marked "community wiki".

asked 15 Feb '11, 22:31

Shifty's gravatar image

Shifty
6114

edited 16 Feb '11, 00:51

i know its not really the answer to your question, but you can use tinyumbrella to kick your phone out of recovery mode.

(15 Feb '11, 22:42) j4yd3e j4yd3e's gravatar image

That only works if the actual firmware flashes onto the NAND at which point iTunes fails due to it being an unsanctioned firmware. At that point you would use TU to kick yourself out of the "fake" recovery mode. (because the firmware is fully flashed and functioning but Apple decided to not let you run it :P)

(16 Feb '11, 00:53) Shifty Shifty's gravatar image

Try putting you device into a pwned dfu mode with redsn0w 0.9.6rc8 and restore to a custom firmware

link

answered 15 Feb '11, 22:50

Rapterf2's gravatar image

Rapterf2
365348

I had this very same problem on my same device with same setup. I moved to another mac and tried the process & was able to complete. It seems not im unable to do any JB related stuff for any device on my imac for some unknown reason ( sync works fine). For what its worth give it a shot on another mac or pc if you can, I know my answer lacks any kind of technical input but sometimes we seem to get wrapped up in the difficulty in simplicity ? Give it a try if you can.

link

answered 15 Feb '11, 22:43

Ashes80's gravatar image

Ashes80
21117

On second thought, make sure that the custom firmware you are using is hactivated as well ensure that all your tools you are using ie.pwnagetool etc. are all up to date latest versions.

(15 Feb '11, 22:47) Ashes80 Ashes80's gravatar image

Alright I'll go give that a try and see what happens. I'll report back.

link

answered 15 Feb '11, 22:44

Shifty's gravatar image

Shifty
6114

link

answered 15 Feb '11, 23:01

Endareth's gravatar image

Endareth
6.7k232439

Rapterf2 was absolutely right :P i had to go into pwned DFU in order to use the firmware. Apparently snowbreeze doesn't do a good job of that :/ THANKS GUYS :)

link

answered 16 Feb '11, 00:49

Shifty's gravatar image

Shifty
6114

Glad to hear you are up and running !

(16 Feb '11, 00:56) Ashes80 Ashes80's gravatar image

Glad to help

(16 Feb '11, 06:44) Rapterf2 Rapterf2's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×3,351
×1,556
×1,524
×1,118
×1,010
×642

Asked: 15 Feb '11, 22:31

Seen: 7,575 times

Last updated: 27 Dec '13, 23:09

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.