Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

Hello, really hoping for some answers here.

I have a iPhone 3g, and trying to upgrade from a jailbroken (via redsn0w) baseband of 05.15.04 on iOS 4.2.1 to baseband 06.15.00 in for the sole purpose of downgrading again in order to unlock the phone via ultrasn0w. Have read all the guides, tutorials, and warnings about this process.

I've made the modified .ipsw via Pwnage using the 4.2.1 firmware and the iPad baseband, as using the latest version of redsn0w it wouldn't let me just upgrade the baseband or select the iPad baseband then upgrade. Using the custom firmware I tried restoring via iTunes but just get the error 1600. Then entering pwned DPU mode and trying to restore through iTunes, still no success, same error. Also redsn0w the redsn0w methods which should work all without ever even touching Pwnage too don't seem to work at all, usually ending with USB connection error or .ipsw not supported.

Anyways, where I'm at now is just a very fancy iPod touch, which I already own. Super keen to get this working. Any ideas or help greatly appreciated.

asked 05 Dec '12, 18:31

ptolemyi's gravatar image

ptolemyi
11125

closed 25 Nov '13, 05:52

justinred's gravatar image

justinred ♦
44.7k73416

The question has been closed for being "Spammed thread" by justinred, 25 Nov '13, 05:52


Grab Redsn0w .9.14b2 from here, while it's not the latest version it seems to work better for 3G's.

You will need the 4.2.1 ipsw. Download it from here if you don't already have it.

If you're on windows make sure to disable any antivirus temporarily and run redsn0w as admin.

  1. Redsn0w- extras- select ipsw- select 4.2.1

  2. Click back and click "jailbreak" on the main screen. --You will come to checkboxes.

  3. Only check "Install ipad baseband" and click next. Follow intructions and let it work. (At some point you should see 'flashing baseband, dont interrupt' on the device itself)

  4. When the phone reboots, verify the baseband is now 6.15 either in redsn0w or in Settings-General-About on phone.

  5. Repeat steps 1 and 2 then at the checkboxes choose "install cydia" (if you dont already have it) and "downgrade from ipad baseband". Hit next. (Again you should see 'flashing baseband' on device)

  6. Verify your baseband is now 5.13.x and simply install Ultrasn0w via Cydia to unlock.

If after either baseband flash your bb, wifi, bluetooth becomes blank, Don't freak out. Just re-run it.

If you get USB errors, try different cords/ports and don't use a hub. Last resort try another computer.

link

answered 05 Dec '12, 18:50

cybr1d's gravatar image

cybr1d ♦
24.3k255636

edited 05 Dec '12, 18:52

Hey Curly, thanks for the in depth reply. Giving this another go with 9.14b2 redsn0w like you said. I'll let you know how everything goes should any other problems come up. Thanks heaps.

(05 Dec '12, 19:04) ptolemyi ptolemyi's gravatar image

No problem :) just let us know how it goes

(05 Dec '12, 19:05) cybr1d ♦ cybr1d's gravatar image

So, all is well with the Upgrade -> Downgrade, and I'm still able to select Wi-Fi and Bluetooth which is nice. The only problem right now is that when I select my wifi network and enter the password, it seems to have lots of trouble connecting. Or if I do get onto the wifi, when I jump into Cydia to finish off the process the wifi disconnects. So close. Any ideas?

Note: Not sure if clearing network preferences will help or not? Or if I need to rerun the whole Upgrade/Downgrade again. Seems weird I can access the wifi but not actually connect.

Edit: Also, there's no information in the ICCID in the about part of the iPhone. Not sure if that has it's own obvious answer or not.

Edit 2: So, I've installed Cydia and the two Substrates to now have a unlocked iPhone 3g (woo) that picks up my carrier fine. Only problem is the Wifi is still not connecting, which means none of the real fun stuff, just a heavy phone.

(05 Dec '12, 19:23) ptolemyi ptolemyi's gravatar image

You can try Settings-General-Reset- "reset network settings" it may help the wifi issue. I'm sure sure what would be causing that..

Whatever you do don't use the "erase all content and settings" button while jailbroken. It will force a restore.

If the reset doesn't help we can try troubleshooting further

(05 Dec '12, 20:48) cybr1d ♦ cybr1d's gravatar image

Yup, tried the reset network settings and between doing that a couple times and rebooting the device, the phone goes in between having the WiFi greyed out or able to select it but unable to connect. The problem now is that while I can go into the WiFi, now the phone doesn't even pick up any available WiFi connections. :/

(06 Dec '12, 13:27) ptolemyi ptolemyi's gravatar image

Also, repeated the process of upgrading and downgrading the baseband again as it seems that's what some other people have suggested. Reset the network settings, then reset all settings, and same story. Can get into the wifi, but when it searches for a network it can't seem to pick anything up.

(06 Dec '12, 14:53) ptolemyi ptolemyi's gravatar image

Have you tried a complete restore?

(06 Dec '12, 14:58) pwnage pwnage's gravatar image

That is to restore via iTunes with the 4.2.1 firmware and repeat all the steps again? Not yet, would like to see if there is another solution I guess before going all the way back to the beginning.

(06 Dec '12, 15:08) ptolemyi ptolemyi's gravatar image

Attempted the full restore with success, followed through to the upgrade baseband steps that Curly originally posted and the phone ended up being stuck on a black screen with the Apple logo eternally. Tried to reboot the device, same story. Attempted to completely restore again but at the very end get the error 1060. Bah.

(06 Dec '12, 16:20) ptolemyi ptolemyi's gravatar image

Managed to get out of the eternal recovery mode. @Curly420. When I attempt your guide from a fresh slate it seems that the phone after first baseband upgrade doesn't work, it may have something to do with not being jailbroken, I'm not sure. But I'm able to downgrade the baseband after that and then install cydia/etc. At the same problem with the phone not picking up any wifi signals though. Might try the full restore then the version of redsn0w ajaybnl has suggested below. bah.

(08 Dec '12, 12:02) ptolemyi ptolemyi's gravatar image
1

If you need to restore use a custom firmware so it preserves your baseband and you won't have to reflash. You can try the older redsn0w but its pointless IMO. .9.14b2 is as good as .9.6.. The bug is only with 9.15.

Your wifi issue unfortunately sounds like a hardware issue.. If it still happened after you restored fresh then it's a guarantee.

(08 Dec '12, 12:20) cybr1d ♦ cybr1d's gravatar image

I was thinking the hardware issue as well, but remembered that after the first jailbreak I did on the phone before upgrading the baseband it was able to connect to wifi really well. So, I'm not too sure. Can anything happen to the hardware during the flashing process? I'll try the restore with a custom firmware now, do you reckon it's wise to do it through Redsn0w .9.14b2 then? Ie. The restore functions via redsn0w with selecting preservation of the baseband?

Edit: By the way, there's everything showing up in the 'about' section except for the ICCID. Not sure if that is playing a role in this problem?

(08 Dec '12, 12:30) ptolemyi ptolemyi's gravatar image
1

Changing the baseband wouldn't affect the wifi like that. It seems like an odd coincidence that wifi would mess up after doing this, but I can't think of anything else other than hardware.

To make a custom with .9.14 use: Extras- Custom IPSW- Give it the 4.2.1 ipsw and it will make a "NO_BB" ipsw.

Then use Extras-PWN DFU- and once you're pwned open iTunes, hold Shift and click restore (alt for mac). Choose the "no_bb"

(08 Dec '12, 12:41) cybr1d ♦ cybr1d's gravatar image

Nice one, thanks for quick reply. Doing this now and I'll let you know how it goes.

(08 Dec '12, 12:45) ptolemyi ptolemyi's gravatar image

After creating the custom IPSW, entering PWN DFU, and trying to alt-restore via itunes I get an error saying: "The iPhone could not be restored. This device isn't eligible for the requested build." Bah! I used the exact same 4.2.1 ipsw for the custom ipsw that i have been using for the full restore when needed as well. :/

(08 Dec '12, 12:51) ptolemyi ptolemyi's gravatar image

lol did it give an error # or just the message?

click here. What do you see?

(08 Dec '12, 12:57) cybr1d ♦ cybr1d's gravatar image

No error number, just the message. As far the link, the page fails to load / Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

Edit: For reference, I'm running on a mac and latest iTunes version.

(08 Dec '12, 13:00) ptolemyi ptolemyi's gravatar image

I have seen many times in my career that broken wifi could recovered with reflashing or downgrading baseband. If not workibg till now: Hardware problem or Corrupted Wifi firmware. I MEAN PERMANENT DISABILITY.

well you can just live without wifi!!!

(08 Dec '12, 13:19) ajaybnl ajaybnl's gravatar image

um i'm confused by that page error. Try it again

(08 Dec '12, 13:21) cybr1d ♦ cybr1d's gravatar image

Edit: Works when I add the http(s) to the link in chrome. Anyways, same things I can see as in firefox. Should I be looking for something in particular though? Apple/Apache Webserver/Technical problems etc.

(08 Dec '12, 13:32) ptolemyi ptolemyi's gravatar image

the "placeholder" page is all I was looking for. That's normal. If you had seen Cydia, then your hosts file would have been wrong. I'm just not sure what could be wrong. You can hop on IRC so we can chat in real time

(08 Dec '12, 13:42) cybr1d ♦ cybr1d's gravatar image

Please ptolmeyi downgrade ur baseband to 5.13 . Using redsnow. To see final result.

(08 Dec '12, 13:46) ajaybnl ajaybnl's gravatar image

thats where it is now

(08 Dec '12, 13:55) cybr1d ♦ cybr1d's gravatar image

Hey curly, after a fresh restore and jailbreaking the phone/installing cydia seems the wifi is still out. Which is weird, because it did work once upon a time.

(09 Dec '12, 05:08) ptolemyi ptolemyi's gravatar image

Conclusion is the update to 4.2.1 fried my WiFi chip, seems like hundreds of user had this problem over the last year or so. Can't be fucked taking the device apart to void the warranty, will try and hustle at the apple store maybe. Used the iPhone Config Utility and get this error when I enter the WiFi connection screen in the log;

Sun Dec 9 19:48:08 iPhone Preferences[115] <warning>: -[APNetworksController scanFailed:]: 65 consecutive scan failures, waiting for next scan interval before trying again

(09 Dec '12, 13:50) ptolemyi ptolemyi's gravatar image

Why do you want to restore? Get redsn0w 0.9.15b3 and the original ios 4.2.1 and upgrade from there.

link

answered 05 Dec '12, 18:44

pwnage's gravatar image

pwnage
96124

Also it depends on your serial number if you can upgrade to 06.15.00 or not.

(05 Dec '12, 18:45) pwnage pwnage's gravatar image

I know, I know, it seems a real around about way when redsn0w 0.9.15b3 offers the full service. For some reason though when I select the upgrade from there, it goes through the whole process but I come out with the exact same phone as before, no upgraded baseband. :/

(05 Dec '12, 18:47) ptolemyi ptolemyi's gravatar image

Right but did you select ios 4.2.1 in select ipsw before pressing jailbreak to upgrade? Also what is the 3rd, 4th and 5th digit of your serial number? Can be found in settings>general>about.

(05 Dec '12, 18:48) pwnage pwnage's gravatar image

I've looked up the serial information before and thought I was in the good, but it's; 851.

(05 Dec '12, 18:50) ptolemyi ptolemyi's gravatar image

@pwnage fyi the serial number thing only applies to 3GS', all 3G are fine ;P

(05 Dec '12, 18:51) cybr1d ♦ cybr1d's gravatar image

Ah, thanks for correcting me on that.

(05 Dec '12, 18:52) pwnage pwnage's gravatar image

@ptolemyi

Youre good anyway, just follow the instructions from Curly below.

(05 Dec '12, 18:53) pwnage pwnage's gravatar image

Can anyone help me please? i have an iphone 3g and have spent the day jailbreaking then unlocking it, getting the wifi to stay connected etc etc. It seems to have all gone fine but now i am getting 'no service' or one bar signal but call failed etc etc. Have tried network settings reset, changing different settings within the iphone that may have been causing this problem and still having no luck. When i ran the jailbreak i didnt select any specific ispw but on the guide i read it did state that it wasnt overly important and could be done after if needed, and i also have no idea what this baseband is? and is this maybe what i have done wrong. Please can someone help i just want my sim to work which i know it does in another phone! my modem firmware is 05.15.04 my model is mb489b im on version 4.2.1 and have a tesco sim card which i know works.

thanks!

link

answered 04 Mar '13, 11:07

djembaf's gravatar image

djembaf
1113

Hi guys.. I think it´s a ultrasn0w 1.2.8 new version bug problem

Well, I have 4.2.1 with 6.15 just flashed, and have signal problems (wi-fi and phone calls) I d flashed with Redsn0w 9.15b3, then 9.14b1, b2, 15b1, b2, etc. Allways get´s the same result. And before reflash, my 3g works fine. While i flash it for jailbreak, i d decide to downgrade to 5.13.x (just because i read it s more stable) then ultrasn0w 1.2.8.

But when the process finish, no baseband, no wi-fi, no nothing (weird!) Then I reflash it, but the only FW accepted is the 6.15.

Tries to connect... but erratic and No Service... I think the Redsn0w fries the comm board ... or do some pemanent damage.. Because no matter if you restore by iTunes to original FW, failure still there (like a hw problem.. ) My Advice: Don t use Redsn0w to reflash BB.. Or perhaps ultrasn0w 1.2.8 have a bug.. (its very "newbie". since november 2012)and just fail in some NOR types..

link

answered 05 Mar '13, 09:29

axelabad's gravatar image

axelabad
111

Ok.. great news! After a lot of attemps reflashing with all alternatives, finally i have 100% functionally Jailbreacked, Unlocked, Hacktivated and happy iPhone 3G 4.2.1 and 5.13.4. Look likes it needs several tries till it does the job well.. Last and success was with Redsn0w 9.14b, extras->Select IPSW official 4.2.1, and only check "Downgrade from iPad baseband". No ultrasn0w needed before reflash...(weird?)

Now Wi-fi, Phone and GPS works wonderfull! =)

(05 Mar '13, 10:40) axelabad axelabad's gravatar image

Oi meu nome é Wislley Egon Peguei um 3G importado de um cliente que não tava pegando operadoras, só funcionou assim: Baixei e o firmware 4.2.1 original Apple;

criei um custom firmware com o sn0wbreeze v.2.9.5 (Só funcionou com essa versão) que achei no 4 sharing e durante a criação do firmware habilitei a opção de incluir baseband do ipad 06.15.00 logo na opção de na opção de expert > Unlock

Depois de criar essa custom firmware assim, coloquei o iPhone em dfu pwned, fiz uma restauração no iPhone pelo iTunes usando o custom firmware que o sn0wbreek criou, blz, iphone atualizado com a custom, mais ainda na tela preza.

Dai coloquei o iPhone em DFU e usei o Redsn0w 0.9.15b3 e selecionei o firm custom e depois em jailbreak marquei cydia, incluir ipad baseband e segui.

quando o iPhone ligou, já ligou com a basebando 06.15.00. dai no cydia intalei o ultrasn0w e pronto!! Funcionando uhuuuuuu!!! Só escrevi aqui porque apanhei muito pra fazer pegar....

link

answered 25 Jul '13, 13:41

wislley%20egon's gravatar image

wislley egon
111

-1

I ran Redsn0w multiple times and have a 3g with 4.2.1 and 05.15.04 from att. It gets to the done screen , screen shows pineapple and says do not interrupt, then screen goes black. It comes back with apple icon and never recovers to anything. What am I doing wrong?

link

answered 08 Dec '12, 20:09

FL%20Ralph's gravatar image

FL Ralph
11

How does that answer @ptolemyi's question? This page is for ANSWERS, if you have a question click "ask a QUESTION" at the top of the page.

(08 Dec '12, 20:53) spockers ♦ spockers's gravatar image
-2

Baseband 5.15.04 not updating to 6.15 ? This will help you.

TRIED redsn0w .9.15.b3 but same baseband, tried snowbreez 2.9.6 for ipad baseband in the ipsw but same results again.

Saw Someone have same problems and pointed to http://www.kittyra1n.com/jailbreak-and-unlock-iphone-3g-4.2.1.html

This version (0.9.6rc18) is a life saver. Just updated baseband to 6.15 and then downgrade to 5.13 and it is unlocked.

REMEMBER TO KEEP THIS VERSION IN YOUR PIT.

link

answered 08 Dec '12, 10:17

ajaybnl's gravatar image

ajaybnl
-35228

edited 08 Dec '12, 13:11

You just didn't read the thread at all did you? .9.15 does have a bug. But they were using .9.14. No need for .9.6, the flashing went fine. Their current issue is WiFi.. Not the baseband.

(08 Dec '12, 12:22) cybr1d ♦ cybr1d's gravatar image
1

btw, by "professional jailbreaker" Do you mean you create jailbreaks? Doubt it. You're just another person taking free tools someone else made and charging $$ for clicking a button...

(08 Dec '12, 12:25) cybr1d ♦ cybr1d's gravatar image

First. i written it when ppl have no chance updating 3g baseband. This procedure has recovered me from that situation

secondly Even earth gives us food for free, that does not means we can get fruits for free. we are only taking some cash for helping others who dont know.

I donated jailbreakers.

(08 Dec '12, 13:04) ajaybnl ajaybnl's gravatar image

My reply is my experience. So let me easy someones life.

(08 Dec '12, 13:06) ajaybnl ajaybnl's gravatar image

I'm only a moderator here. I guess I don't have enough experience..

But again.. Did you even read the thread? The issue is not flashing the basebands.. That was solved 2 days ago.

(08 Dec '12, 13:17) cybr1d ♦ cybr1d's gravatar image

Sorry, now got the thread.. Just found the success for the the 3g problem and curius to tell my experience.

You are doing good. Thanks.

But the wifi problem should be discussed on another thread. So that people with similer problems can find them.

(08 Dec '12, 13:40) ajaybnl ajaybnl's gravatar image

kittyrain hahahahah

(08 Dec '12, 20:56) spockers ♦ spockers's gravatar image

Laughing is good for health.

(09 Dec '12, 01:26) ajaybnl ajaybnl's gravatar image

Indeed. Thank you sir.

(09 Dec '12, 01:40) spockers ♦ spockers's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×641
×373
×83

Asked: 05 Dec '12, 18:31

Seen: 70,076 times

Last updated: 25 Nov '13, 05:52

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.