Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i have an ipod 4G and i want to jailbreak it. i have iOS 6 so i needed to downgrade. so i downloaded iOS 5.1.1 to my computer and then i hooked up my ipod to itunes. i already put to make so that itnues contacts cydia not apple. so i put my ipod into DFU mode and it detected it. so i Shift+Clicked the restore button and hit the software i wanted to restore to. i got error 3194 again after i changed my hosts file to defy that error. please help i have tried everything. any suggestions will be appreciated, thanks.

asked 13 Nov '12, 20:39

Matt5378's gravatar image


You cant just point at cydia for 5.x.x you either have to build a stitched firmware with the 5.1.1 shsh or use redsn0w (extras>even more>restore (point it to 5.1.1 ipsw and shsh).


answered 13 Nov '12, 20:41

theiphoneguy's gravatar image

theiphoneguy ♦

thanks guys but i also read that online and i tried it. i got the ispw but then hit the local button and then openned it but then it said it cant verify the SHSH so i dont know what to do

(13 Nov '12, 21:13) Matt5378 Matt5378's gravatar image

oh i hit verify and am verifying my SHSH it says redsn0w has stopped working atm so ya, hope it works!

(13 Nov '12, 21:16) Matt5378 Matt5378's gravatar image

hit remote and it will check cydia for the shsh

(13 Nov '12, 21:16) theiphoneguy ♦ theiphoneguy's gravatar image

ok thanks! and so after i verify this, then will error 3194 go away and i will be able to downgrade using itunes like normal?

(13 Nov '12, 21:20) Matt5378 Matt5378's gravatar image

oh and where is remote? i cant find where that is

(13 Nov '12, 21:24) Matt5378 Matt5378's gravatar image

in redsn0w>extras>even more, click restore. Top button point it to the 5.1.1 ipsw. After you do that the 2 buttons below it are local and remote

Edit - i guess on ipods it doesnt do that, after you tell it 5.1.1 ipsw it'll have you put it into dfu and it will go from there

(13 Nov '12, 21:27) theiphoneguy ♦ theiphoneguy's gravatar image

So go into edit mode? So extras, and then even more? There isn't that when I do it

(13 Nov '12, 21:40) Matt5378 Matt5378's gravatar image

edit was indicating where i added more to my response lol.

Click extras. Click even more. Click restore. Click the ipsw button and direct it to the 5.1.1 ipsw file and follow redsn0ws on screen directions

(13 Nov '12, 21:43) theiphoneguy ♦ theiphoneguy's gravatar image

Edit - never mind aha ok so go into where? Stitch? I need to verify it with Curia cuz it says cannot verify so I need to verify it manually and then go into where from there? I am not familiar with this sorry. I need like steps or something. Do I go into select ispw or custom ispw?

(13 Nov '12, 21:43) Matt5378 Matt5378's gravatar image

Ya aha I got edit before u said that :/ anyway, there isn't an even more box

(13 Nov '12, 21:46) Matt5378 Matt5378's gravatar image

Edit - there may be a restore ill check but there isn't an even more

(13 Nov '12, 21:47) Matt5378 Matt5378's gravatar image

are you using redsn0w 15b3? You should be

(13 Nov '12, 21:48) theiphoneguy ♦ theiphoneguy's gravatar image

and remove the line you added to the hosts file (wont matter for now, but you'll have issues later if you leave it)

(13 Nov '12, 21:49) theiphoneguy ♦ theiphoneguy's gravatar image

I am using redsn0w but it's the newest one I think

(13 Nov '12, 21:49) Matt5378 Matt5378's gravatar image

It's redsn0w 0.9.10b5c

(13 Nov '12, 21:51) Matt5378 Matt5378's gravatar image

I'm searching and there is no 15b3

(13 Nov '12, 21:53) Matt5378 Matt5378's gravatar image

See our links page, it's at the top.

(13 Nov '12, 21:55) spockers ♦♦ spockers's gravatar image

ok thanks i tried downloading it already but it just downloaded setup.exe but its working this time and i dont know what is differnt thanks

(13 Nov '12, 21:59) Matt5378 Matt5378's gravatar image

There is no setup.exe. I have no idea what you're downloading and/or doing.

(13 Nov '12, 22:03) spockers ♦♦ spockers's gravatar image

it downloads a zip file, not an exe. There is no setup.exe in any of the redsn0w files. The only exe included in any of the redsn0ws is redsn0w.exe

(13 Nov '12, 22:03) theiphoneguy ♦ theiphoneguy's gravatar image

yeah it was the 15b3 but then it downloaded setup.exe its weird. it wont detect my ipod in DFU mode what do i do?

(13 Nov '12, 22:04) Matt5378 Matt5378's gravatar image

check your computer for infections

(13 Nov '12, 22:05) theiphoneguy ♦ theiphoneguy's gravatar image

You may well have malware on your system, and it's not from here -- that setup.exe should be worrying you, I know it would me.

(13 Nov '12, 22:06) spockers ♦♦ spockers's gravatar image

if you saved the setup.exe that was downloaded, go over to and have it scanned

(13 Nov '12, 22:09) theiphoneguy ♦ theiphoneguy's gravatar image

it says i cant enter DFU mode i can only enter recovery mode

(13 Nov '12, 22:13) Matt5378 Matt5378's gravatar image

its fine i have the file now

(13 Nov '12, 22:13) Matt5378 Matt5378's gravatar image

i cant seem to have it work when i go into DFU mode

(13 Nov '12, 22:14) Matt5378 Matt5378's gravatar image

what antivirus do you have on the computer?

(13 Nov '12, 22:17) theiphoneguy ♦ theiphoneguy's gravatar image

i have no clue. i gotta go to bed though. agh! it wont let me get into dfu mode! it wont detect anything

(13 Nov '12, 22:31) Matt5378 Matt5378's gravatar image

Plug device into computer via USB. Don't look at the device, concentrate on the counting. Hold home+power for 10 seconds, then release power but keep holding home for 12 more seconds. Screen should be black. That's DFU. You don't need software to get to DFU, just 5 volts USB power and proper button press timing.

(13 Nov '12, 22:35) spockers ♦♦ spockers's gravatar image

don't forget the "bottoms" tutorial spockers..

(13 Nov '12, 22:57) JuergenWest ♦ JuergenWest's gravatar image

I did do that and it does go black. The screen flashes and then goes black but it says that it doesn't detect it and I wanna know y

(14 Nov '12, 07:31) Matt5378 Matt5378's gravatar image

You can't just change your hosts to restore to 5.x.

If you have SHSH go to Redsn0w- Extras- Even More- Restore- give it the IPSW and SHSH blobs.

If you dont have shsh youre out of luck.


answered 13 Nov '12, 20:41

cybr1d's gravatar image

cybr1d ♦

edited 13 Nov '12, 20:41

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 13 Nov '12, 20:39

Seen: 8,961 times

Last updated: 14 Nov '12, 07:31

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.