Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I just spent 13 hours doing this on a 2009 3GS. The problem was the order of the procedure and setting the Base Band (BB) to 06.15.00. Warning: You have to make sure the BB is 06.15.00 (or another compatible BB listed on and not higher otherwise, you’re screwed.

  1. Upgrade to 6.0.1 via iTunes UNLESS you have 3GS made after week 28 of 2011. There are many articles written about why this will brick your phone so feel free to Google those for an explanation.
  2. List item
  3. Get Redsn0w version 0.9.15b3
  4. Download iPhone2,1_6.0_10A403_Restore.ipsw
  5. Follow the jailbreak procedure here:
  6. Don’t do the “Just Boot” thing yet (this is where I kept getting the missing keys bullshit)
  7. Jailbreak the phone again using the same procedure listed before, but uncheck the “install Cydia” box and check the “install iPad Base Band” box and say you’re sure. AGAIN, verify this is what you want to do! If you have a late model 3GS, DO NOT TRY THIS! IT WILL BRICK YOUR PHONE!
  8. Do not try to “Just Boot” the phone yet.
  9. After the 2nd jailbreak, your phone will be on. Go into the Cydia app and install Ultrasn0w. There are plenty of articles written on this.
  10. Go into Cydia app again and install Untrasn0w Fixer 6.0 NOT 6.0.1! Note: If you’re planning on using the iphone with T-Mobile, you need to turn off 3G in the settings on the phone. This goes for any network without 3G service.
  11. Go back into Redsn0w and follow the “Just Boot” procedure.
  12. The iPhone should reboot with a pwnapple logo.
  13. Ta-Da!

Lastly, try to not turn your phone off. This is a tethered jailbreak so if you turn your phone off, you will need to boot up the phone via Redsn0w to get the jailbroken functionality again. I also repaired disk permissions a few times in conjunction with this jailbreak. I don’t know if that helped, but it didn’t hurt.


The only change I would make to these directions would be after you do the 2nd JB and iPad BB install, tether boot it then or else cydia won't show up.

This question is marked "community wiki".

asked 04 Nov '12, 01:55

swagmasterT's gravatar image


edited 04 Nov '12, 01:32

kirb's gravatar image

kirb ♦


So. Which specific step fixed the error here?

(04 Nov '12, 01:35) justinred ♦ justinred's gravatar image

I would say installing the iPad BB, even though I already had it, Did it. It was also the order in which you do the steps that fixed it as well. I followed this guide and am now fully jailbroken and running on tmobile with the ultrasnow 6.0.1 fix.

(04 Nov '12, 01:47) swagmasterT swagmasterT's gravatar image

If you really want to verify if it's really the iPad baseband that fixed it, do redsn0w downgrade baseband, then reboot to see if you get the missing keys.plist error on just boot.

(04 Nov '12, 01:55) justinred ♦ justinred's gravatar image

After everything I went through to get this thing working, I think I'll stay right where i'm at. :D If theres any other people that were having this problem that would like to try what @justinred suggested, feel free!

(04 Nov '12, 01:59) swagmasterT swagmasterT's gravatar image

@justinred There may just be a redsn0w bug where jailbreaking + installing Cydia + installing the iPad baseband + just booting in that order works fine, while doing those steps in a different order doesn't work.

(04 Nov '12, 02:01) britta britta's gravatar image

@britta thats what I was thinking. Maybe its just a bug in the new beta. Who knows.

(04 Nov '12, 02:05) swagmasterT swagmasterT's gravatar image

Glad you figured this out! It shouldn't be this hard to get redsn0w to work; we'll ask MuscleNerd to look into this and hopefully figure out a fix for future versions of redsn0w.


answered 04 Nov '12, 01:52

britta's gravatar image


:D Yes! I Know I'm not the only one in the community and on other places that are having this issue as well, so I figured I would share it here.

(04 Nov '12, 01:55) swagmasterT swagmasterT's gravatar image

Just want to share my experience on my iPhone 4 6.0.1FW I was getting that "missing key.plist" error as well. All that I had to do was after manually choosing 6.0FW prior to jailbreak process was go back in and manually choosing the 6.0FW again before "Booting Tethered".


answered 04 Nov '12, 12:12

Rm305's gravatar image


I can't say this myself, but I know I had to do that at every TB as well.

(04 Nov '12, 12:40) swagmasterT swagmasterT's gravatar image

First i updated it to 6.0.1 then i jailbreaked it to 6.0.0 but i didnt get cydia?

Help me please? And when i do Just boot i get Missing Keys shit! i dunno what to do...


answered 06 Nov '12, 17:13

sajad's gravatar image


edited 06 Nov '12, 17:15


You have to boot tethered. Follow the instructions.

(06 Nov '12, 17:16) spockers ♦♦ spockers's gravatar image

SwagMaster: Quick Question...After the FIRST JB, after you manually select the 6.0FW, did you go through the JB process AGAIN ---OR---, "just reboot tethered"??? This is kicking my butt...Have tried at least 6 times in the last month with no luck so far...Grrr...


answered 13 Dec '12, 09:41

drajha's gravatar image


Disregard!!! Whoop-Whoop!!! After the FIRST JB, I manualy selected the 6.0 IPSW, then immediately "Just Reboot"...Bam!!! I'm in...THANKS!!!


answered 13 Dec '12, 09:46

drajha's gravatar image


Trying to jailbreak verizon iphone 4, redsn0w says missing keys.plist etc.. phone is on iOS 6.0.1


answered 16 Dec '12, 00:25

Sat's gravatar image



Using snowbreeze to update iOS 6.1 for iphone 3Gs work well and jailbreak.


answered 16 Feb '13, 23:04

halim2731's gravatar image


That's very helpful, now that evasi0n is out, thanks!

(16 Feb '13, 23:08) spockers ♦♦ spockers's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 04 Nov '12, 01:55

Seen: 53,052 times

Last updated: 24 Apr '14, 02:13

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.