Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

More of an advanced question but I'll give it a shot. I've been developing a mobilesubstrate plugin for some time now. Been testing it on my own and friends' devices for months and I've gotten it to be fully stable on 4.0 and newer. All of a sudden after using GP (installed on top of redsn0w tethered) every single app purchased from the app store crashes on launch. Built in apps and cydia apps do not crash. Are there any known sandbox bugs in GP I should know about? Anything else GP specific that could cause this? Who do I talk with about identifying this bug?

Just for kicks I have tried a few other things:
- restored in iTunes and JB with redsn0w tethered = no crashes
- restored in iTunes and JB with GP (no redsn0w first) = crashes

Looks like GP is causing the issue, I just have no idea why. Please help!

asked 04 Feb '11, 17:20

smitty078's gravatar image

smitty078
51216

edited 04 Feb '11, 18:57

chpwn's gravatar image

chpwn ♦
1.2k3712


$ gdb
(gdb) attach -waitfor NameOfSomeAppStoreApp
(gdb) cont

see where the crash comes from. (Also, if you're not looking at the syslog, install the "syslogd" package and see what's printed to /var/log/syslog.)

link

answered 04 Feb '11, 17:23

comex's gravatar image

comex ♦
3.3k102629

edited 04 Feb '11, 17:23

I'm getting "deny file-read-metadata" from cache files in /User/Library/Caches/mysubstrateplugincachedirectory from sandboxd I fixed the crash for now (but have no cache) however it looks like the actual issue lies in sandbox. Issue exists with GP and not with RS

(04 Feb '11, 17:41) smitty078 smitty078's gravatar image

I don't remember which version does what, but I think it may have worked only because the jailbreak broke the sandbox entirely. This is not a good idea, because sandboxing can be an effective security measure; on the other hand, the current alternative is a hack which is hardcoded to whitelist stuff outside of /var or inside /var/mobile/Library/Preferences (for MobileSubstrate tweaks). I hadn't thought of Cache when I wrote it.

Unfortunately, I have to recommend that you stick your cache in Library/Caches/com.apple.keyboards/, which should be allowed by the sandbox.

(04 Feb '11, 17:48) comex ♦ comex's gravatar image

Thanks, that works (although not necessarily pretty but I understand why).

(04 Feb '11, 18:19) smitty078 smitty078's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,847
×245
×53
×25

Asked: 04 Feb '11, 17:20

Seen: 2,785 times

Last updated: 04 Feb '11, 18:57

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.