Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

Okay, Long story short: JBQA - iPhone - Begintopic.

I tried updating my iPhone 4 (bb 1.59.00) to 4.2.1 trying to preserve my baseband. I followed the tutorials, including the more detailed one on iClarified.

While trying to update to 4.2.1, I followed each step as stated, I received error 1604. The guide states Whenever a 16XX error pops up, try placing the device in DFU mode. And restart at step 5. Tried this when after trying to restore firmware 4.2.1, iTunes states error 1600.

After retrying this matter for a couple of times. I downloaded FW 4.0.2, trying to restore to my previous FW. Now iTunes pops up giving me error 1004.

Please help me,

Kind regards, Kj~

asked 14 Feb '11, 14:52

Kjeld's gravatar image

Kjeld
114327


After some struggle, and using google and Bing. I stumbled upon this link RecBoot

Basicly what I tried and did, was restoring my iPhone using it's previous FW (4.0.2). iTunes gave me the 1004 error. But I read somewhere during my quest in order to find answers, that whenever error 1004 pops up the firmware is finished installing but needs a helping hand in order to get out of recovery mode.

I didn't change the host file in /etc/, but already tried removing the cydia-link to *gs.apple.com*. Now I've finally activated my phone, running on 4.0.2 (BB 1.59.00)

Now I'm back to square one. Trying to get my phone updated to 4.2.1.

link

answered 14 Feb '11, 15:26

Kjeld's gravatar image

Kjeld
114327

Glad to hear you're still safely on 01.59.00. Hope trying again with TinyUmbrella works for you like it did for me.

(14 Feb '11, 15:33) gomanski gomanski's gravatar image

BTW, not sure if it would work in this case, but TinyUmbrella can also kick (some) devices out of recovery (sometimes); in this case, I think it would have worked for you. Sorry I didn't think of that!

(14 Feb '11, 15:34) gomanski gomanski's gravatar image

i haven't faced any problem like 1004 or 1604...but according to gomanski if you faced error 1013 here's the solution

link

answered 14 Feb '11, 15:23

yousafkh's gravatar image

yousafkh
(suspended)

When you got the 1604, had your restore started yet?

I believe I got a 1604 error when trying to JB my iPhone4 with GP RC5, but it hadn't begun the restore process yet, it had just timed out.

In that case, I just needed to reboot my Macbook Pro and try again. The next time around, I got the 1013 error as expected.

The 1004 error, according to this thead, has to do with gs.apple.com being rerouted by TinyUmbrella or to Saurik's server.

I would reccomend rebooting your machine, and following the TinyUmbrella steps again.

link

answered 14 Feb '11, 15:13

gomanski's gravatar image

gomanski
2.3k78

1013 is the error I need to receive in order to know the update, preserving my baseband, was successful. But reading my answer resolves this matter.

link

answered 14 Feb '11, 15:27

Kjeld's gravatar image

Kjeld
114327

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×2,575
×1,010
×623

Asked: 14 Feb '11, 14:52

Seen: 3,631 times

Last updated: 14 Feb '11, 17:17

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.