Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

i all- this is my first post. I spent a while looking for posts on this, but came up empty for this issue. If anyone can link to a previous thread that discusses this, please do.

So I have an iPhone 4 (as the thread title would suggest) and here's some data on it:

Version: 4.0.1 FW: 01.59.00

I just saved the SHSH blobs today using tinyumbrella. It was the first time for this phone. After doing so, the TSS server runs with no errors.

I attempted to upgrade to 4.2.1 using the option restore method after downloading the IPSW(basically followed a tutorial, though it was lacking any information about baseband and updating from iOS 4.0.1), but iTunes said the firmware version was not found or something.

Why is that?(I want to understand these details better and I have read a lot of sites and forums about it- but even tutorials leave out what seem to be important details and/or steps- and I've been going to what seem to be the authoritative sites(won't name them here, just give associated words so as not violate any forum rules about other sites): clarify, r-pie, and iDB and this site.

I want to jailbreak and unlock as I will be outside my home country(US) for several months.

Do I need to update to 4.2.1 in order to use the new greenpoison jailbreak? Is there a jailbreak package for 4.0.1 that someone can recommend? Isn't it best to have the latest iOS that still allows for unlocking?

I have another iPhone 4(one is mine, one is gf's) with 2.10.04 BB and it is (greenpoison)jailbroken on 4.2.1 and I eagerly await an unlock crack for it. For now, I just want to get my gf's prepped for travel and use in GB.

If some can just say, "Listen dude- get your iOS to _ version and your BB is at, but make sure that you don't ___. Then download version of (jailbreaking software), and then unlock using_" that wold be awesome. Links, too. Thanks so much in advance! This site seems pretty cool, I just found it and seems like a good community.

asked 14 Feb '11, 04:21

kurichan's gravatar image

kurichan
111


For the 4.0.1 you can browse from Safari to the jailbreakme.com site, and slide the bar to jailbreak, its that simple.

for upgrading to 4.2.1, use TinyUmbrella and follow instruction on the below site to avoid upgrading the baseband:

http://thefirmwareumbrella.blogspot.com/p/prevent-iphone4-baseband-update.html

BB 1.59 can be unlocked with current Ultrasn0w 1.2 BB 2.10 unlock is still not released, this will be released after FW 4.3 release.

the instruction on the site above are pretty clear, let me know if you get stuck despite that, i will try to help you with as much details as possible.

link

answered 14 Feb '11, 04:42

knightz4u's gravatar image

knightz4u
4.9k91828

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×8,194
×2,358
×642

Asked: 14 Feb '11, 04:21

Seen: 1,350 times

Last updated: 14 Feb '11, 04:42

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.