Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.0-8.1 is released (instructions) - see /r/jailbreak on Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

So i decided to install firmware 4.2.1 but i cant manage to pass the recovery mode; ive tried tinyumbrella in DFU mode,tinyumbrella (fix recovery DFU mode), redsnow,greenpoison while having itunes opened... but someway somehow when i trigger any of this resources and use the fix recovery option it does nothing, my iphone stays blackscreen. Even tried jailbreaking it just leaves me same place.(recovery mode) I can go back and install IOS 3.1.3 with no problems but i really do want to try 4.2.1. I really do need smart and accurate solutions. Ex Dont tell me im entering DFU mode wrong (done that in every single way) Thanks for reading and if you know the way let me know please/

This question is marked "community wiki".

asked 01 Oct '12, 04:47

afilelektro's gravatar image

afilelektro
0112


Have your host file point to apple server, be in pwned dfu mode and restore to a custom 4.2.1 ipsw.

link

answered 01 Oct '12, 04:51

justinred's gravatar image

justinred ♦
47.1k74217

When i run Tinyumbrella it shows im in IOS 3.1.3 but im not also shows my baseband 06.15.00-6.4_M3S2. Im a windows 7 64 bit user; could you explain me please justinred how to try that. Thanks appreciate the quick response.

(01 Oct '12, 04:55) afilelektro afilelektro's gravatar image
1

Intentionally left out links on my above reply thinking you wanted a "techie" answer. lol. See this FAQ entry on how to point host file to apple servers. Create a 4.2.1 custom ipsw using sn0wbreeze 2.9.6 simple mode. Sn0wbreeze will guide you on how to place device in pwned dfu at the end of the process before you shift+restore in iTunes. You also want to downgrade your baseband to 5.13 using redsn0w 9.14b2 to fix your gps. Final step is to install ultrasn0w from cydia to unlock.

(01 Oct '12, 05:08) justinred ♦ justinred's gravatar image

Thanks alot justinred it worked the baseband downgrade too. Im now with 05.13.04-6.4_M3S2. Still had a bit of issues but because of my pc : usb thing,firewall,rebooting..etc At the end i got a jailbroken 3G IOS 4.2.1.

Do you know why i was having this problem? was beacuse of the baseband thing?

Also what steps i have to repeat when going back and forward IOS 3.1.3 -> 4.2.1?(have to create custom ipsw or can i do it the way normally i was doing "exit recovery or fix recovery + redsnow)

Thanks again bro =D

(01 Oct '12, 17:26) afilelektro afilelektro's gravatar image

It was tinyumbrella messing up restore, you don't need tiny since 4.2.1 is still being signed and is the latest firmware for 3G. If you rely on ultrasn0w unlock, always use a custom ipsw when restoring.

(01 Oct '12, 20:08) justinred ♦ justinred's gravatar image

Yea I always use ultrasnow, the thing is when i have to activate my iphone lucky me i have a spare at&t sim card

(01 Oct '12, 23:17) afilelektro afilelektro's gravatar image

go to itunes and restore it or use recboot or tinyumbrella to exit u out.

link

answered 01 Oct '12, 17:32

james1000's gravatar image

james1000
4110215

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×381
×304
×104
×74
×22

Asked: 01 Oct '12, 04:47

Seen: 14,761 times

Last updated: 02 Oct '12, 01:19

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.