Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

hey! i was forced to upgrade to ios 6 (got a replacement phone) on my iphone 4. so far, everything works just great. i managed to install cydia 1.1.6-ios6 and most tweaks i need. then, i tried 3denabler - you know, flyover on iphone 4 - and i got stuck on the apple logo (both respring as well as reboot). i then tethered rebooted the iphone while holding volume-up, uninstalled the tweak in cydia and again tethered rebooted the iphone, while not-holding volume-up. but: mobile substrate didn't load, and i'm not in safe mode.

any ideas?

ps: i had this one a few days ago, i uninstalled mobilesubstrate and all tweaks that use it and reinstalled them all - worked again. but i don't want to do this again...

asked 27 Sep '12, 15:50

senthor's gravatar image


Mobile Substrate has not been updated to properly work on iOS 6 so you should expect errors and drawbacks.


answered 27 Sep '12, 16:07

reV17's gravatar image


edited 27 Sep '12, 16:08

What happens if you respring? (Install something from Cydia to get it to prompt a respring.)

If that doesn't help, what happens if you tethered-reboot again?


answered 27 Sep '12, 17:08

britta's gravatar image


tethered-rebooting has no effect, respringing neither. seems like mobilesubstrate doesn't allow any kind of rebooting on ios6, works flawlessly besides to that.


answered 28 Sep '12, 18:45

senthor's gravatar image


I had The same problem but solved it by resetting and rejailbraking my iPhone 4. Now is working fine (stay away from unlock ios6 maps too!!), but if i get stucked once again in respring loop what do i have to do? I didn't understand. I have to reboot The iPhone pressing The volume up button and then reboot it with redsnow, then delete mobile substrate and finally reinstall it with all The tweaks? Si that correct?


answered 28 Sep '12, 19:03

RomaCaputMundi's gravatar image


If you get stuck in respringing, connect your iphone to your mac/pc, do a hard reset (press power and home simultaneously until you see the apple logo, then stop pressing home but keep sleep pressed, wait three seconds, press home again and keep pressing sleep, wait for ten seconds, and stop pressing sleep but keep pressing home for 10 seconds. You are now in DFU mode, immediately after the hard reset. You can then boot normally with redsn0w, without pressing volume up. If you're lucky you will be in substrate safe mode and can uninstall the bad tweak and respring. If you're unlucky everything will work - but not mobilesubstrate - and you can unistall the bad tweak. Then, you have to uninstall mobilesubstrate completely - no immediate reinstall. Then, install mobilesubstrate again, and install all tweaks that were removed with mobilesubstrate (but not the bad one!).

(29 Sep '12, 06:08) senthor senthor's gravatar image

thank's a lot! resetting and rejailbraking was a real waste of time... ;)

(29 Sep '12, 11:37) RomaCaputMundi RomaCaputMundi's gravatar image

You could also install semi-tether so that you can reboot without using redsn0w.... One thing though, your JB tweaks won't work.....


answered 29 Sep '12, 13:18

surej96's gravatar image


Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 27 Sep '12, 15:50

Seen: 6,668 times

Last updated: 29 Sep '12, 13:18

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.