Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

evasi0n7 can jailbreak iOS 7.0-7.0.6 untethered. p0sixspwn can jailbreak iOS 6.1.3-6.1.5 untethered (see here for 6.1.6).
How to jailbreak iOS 7.0-7.0.6 (and fix problems). iOS 7.1.x is not jailbreakable, except an unsupported tethered iPhone 4 jailbreak.
Restoring or updating will update your device to iOS 7.1.1 and remove your jailbreak. There is no way to downgrade from iOS 7.1.x to 7.0.x.

Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to chat, you can join us here (irc.freenode.net #JailbreakQA). Chat rules.

I recently bought an iPhone 4 from an individual and he told me it had been jailbroken (I don't know what program), so when I got home I restored it and backed up my old iPhone information onto it. About an hour later it turned off and went into, I think, recovery mode. Now when I plug it into my laptop, it shows the USB cable connecting to iTunes picture, so I try to restore it. It begins the restore, and then the phone just shuts off, and iTunes says error 21. I don't know how to fix this! Someone PLEASE help!!

asked 15 Sep '12, 16:25

paulc's gravatar image

paulc
11112

Tell me what you see when you click this: http://gs.apple.com

(15 Sep '12, 16:26) spockers ♦ spockers's gravatar image

"This page is just a placeholder" ?

(15 Sep '12, 16:28) paulc paulc's gravatar image

OK, your hosts is fine. Have you updated iTunes?

(15 Sep '12, 16:33) spockers ♦ spockers's gravatar image

I believe so, I restored and backed up the iPhone I'm currently using and it did fine. If I click "Check for updates" in iTunes, it says that iTunes 10.7 is available but when i click download it doesn't do anything.

(15 Sep '12, 16:36) paulc paulc's gravatar image

That is odd, but probably not relevant. Is the laptop your only computer? I'm thinking try a different one if that's an option. EDIT: I just tried updating iTunes and got the same result you did, very strange.

(15 Sep '12, 16:39) spockers ♦ spockers's gravatar image

It's my only computer. I let my friend on campus try to fix it, he buys and sells smartphones so he knows a little about them, and I think he tried restoring on his computer too, but it still didn't work.

(15 Sep '12, 16:42) paulc paulc's gravatar image

Sounds like the dock connector is hosed then, which might explain why the seller was selling it. I'd give it a close look with a flashlight and magnifying glass, and clean it with a dry toothbrush. Error 21 is dock connector (it can also be hosts but we've already ruled that out).

(15 Sep '12, 16:50) spockers ♦ spockers's gravatar image

But if it was that, I wouldn't have been able to connect it and restore and back it up the first time, right?

(15 Sep '12, 16:52) paulc paulc's gravatar image

That's true. It could be loose, though, or maybe there's debris covering or shorting out a couple of pins.

(15 Sep '12, 17:17) spockers ♦ spockers's gravatar image

I cleaned it out with a toothbrush tip and blew in it, it still didn't work. I don't think it's the dock connector or pins.

(15 Sep '12, 17:27) paulc paulc's gravatar image

I'm fresh out of ideas then.

(15 Sep '12, 22:59) spockers ♦ spockers's gravatar image

Dang :/

(15 Sep '12, 23:05) paulc paulc's gravatar image

Try placing your phone in DFU mode and then attempt a restore. If you can try a different cable.

link

answered 15 Sep '12, 16:31

reV17's gravatar image

reV17
3.7k12620

It's in recovery mode and won't go into DFU mode.

(15 Sep '12, 16:37) paulc paulc's gravatar image

I'm pretty sure you can go into DFU mode from Recovery Mode. Have you tried another cable? Or another computer?

(15 Sep '12, 16:44) reV17 reV17's gravatar image

I've tried several different things, but you tell me how to get it into DFU mode. I have tried another cable, and I think my friend tried it on his computer too.

(15 Sep '12, 16:46) paulc paulc's gravatar image

Plug device into computer via USB. Don't look at the device, concentrate on the counting. Hold home+power for 10 seconds, then release power but keep holding home for 12 more seconds. Screen should be black. That's DFU. iTunes will call it recovery mode, but if the phone's screen is black, it's DFU.

(15 Sep '12, 23:12) spockers ♦ spockers's gravatar image

You can use tinyumbrella to exit recovery, but right after that, you have to immediately try putting it on dfu mode. also, your best bet is to use redsn0w to enter pwned dfu mode after you put your device in dfu so itunes will most likely not give you any error messages.

link

answered 20 Feb '13, 00:53

theswagninja's gravatar image

theswagninja
111

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6,783
×2,837
×1,264
×683
×404
×88
×17

Asked: 15 Sep '12, 16:25

Seen: 5,626 times

Last updated: 20 Feb '13, 00:53

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.