Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

There is no jailbreak for iOS 8 yet. How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

Hey guys, I got my Apple TV2 two weeks ago and jailbroke it with SeasonPass on a friends mac. The electricty went out a week later and so I was stuck with it needing to be rebooted while being tethered to the computer, problem was I didn't have access to a mac. So I just let it sit there until last night when GreenPoison RC6 came out. I tried to run the jailbreak over it and nothing worked. So I tried to just restore to the stock 4.2.1 firmware and I kept getting errors 1604 and 1603. The last two I have gotten were 1603. Any suggestions on what I may be doing wrong? Thanks in advance for the help!

This question is marked "community wiki".

asked 13 Feb '11, 10:35

prunerepairs's gravatar image

prunerepairs
16112


Tips for the error codes: 1) Make sure no other iOS device is connected to your computer 2) Make sure WiFi Sync hasn't been running since you started up your computer 3) If you see multiple Apple TVs in iTunes, eject both of them and reseat the USB cord. 4) Connect only with the micro USB cable (no power) 5) Reboot (Menu + Down Arrow) and then immediately DFU before the iTunes restore 6) Your Apple TV will still boot fine after 16xx messages. Sometimes you can ignore these errors. Sometimes custom firmware will trigger these errors. 7) Try running Tiny Umbrella and turn on the TSS server (if you have your blobs backed up first) before launching iTunes to do the restore.

link

answered 15 Feb '11, 07:33

prokizzle's gravatar image

prokizzle
148319

The only thing connected to my computer is the ATV2.I have Wifi Sync installed but it is also not running at all. Is there a difference between recovery mode and dfu mode on an ATV2 like there is on an iphone? My ATV2 will not boot after any of the 16xx error messages. When I hook it up to the tv it still shows the "connect to itunes" logo. I don't have any blobs backed up for the ATV2 so running the TSS server would be pointless correct? The only thing it sounds like is maybe I'm not getting the ATV2 into dfu mode? Is there a way to tell if its in dfu mode as opposed to recovery mode? THANKS!

(17 Feb '11, 12:52) prunerepairs prunerepairs's gravatar image

Tiny umbrellas log section will tell you, as will hardware growler

(17 Feb '11, 13:25) prokizzle prokizzle's gravatar image

Completely disconnect the AppleTV from everything. Make sure iTunes is completely up to date. Plug only the USB cable. Try the restore again.

link

answered 13 Feb '11, 10:46

TechLife's gravatar image

TechLife
804

I have tried it now three times like you said and keep getting error 1611 now. Here's what Apple's site says "Error 23, 28, 29, 40, 1002, 1011, 1012, 1014, 1611: These errors may indicate a hardware issue with your device. Follow the steps in this article and also attempt to restore while connected with a known-good 30-pin Dock Connector cable, computer, and network to isolate this issue to the device. If the MAC address is missing or the IMEI is the default value (00 499901 064000 0), this can also confirm a hardware issue." I'm getting really frustrated with this. Apple doesn't have much when it comes to support for the Apple TV. Any other ideas?

(13 Feb '11, 15:17) prunerepairs prunerepairs's gravatar image

Well it was worth a shot...worked fine for me. No errors whatsoever.

(13 Feb '11, 16:22) TechLife TechLife's gravatar image

I am still getting the 1611 error, I have hooked up the ATV2 and it is stuck on the recovery symbol. Is tinyumbrella supposed to recognize my apple tv? Nothing shows up when I hook it up to my computer in TinyUmbrella.

(13 Feb '11, 18:48) prunerepairs prunerepairs's gravatar image

Yes. But it has to be connected to power and booted up before it will recognize it. Otherwise you have to enter your ECID manually.

(13 Feb '11, 18:51) TechLife TechLife's gravatar image

What do you mean enter the ECID manually? I see where it gives me that option but I assume I'd need to know the exact one of the Apple TV I have right? Thanks for all the help so far btw!

(13 Feb '11, 23:00) prunerepairs prunerepairs's gravatar image

Yes, you do need to know the ECID of your specific device to enter it manually. I don't know if there is anyway to find it if you don't have it...sorry.

(14 Feb '11, 20:43) TechLife TechLife's gravatar image

I don't think you should run the Jailbreak over Seasonpass. I recommend restoring the firmware from iTunes and then running GP RC6. You will have issues putting the ATV2 into recovery mode. So I used TinyUmbrella to put the ATV2 into recovery. Then I restored it to a fresh install of 4.2.1. And then I ran GP RC6. Something to note as well is for some reason, restoring the ATV2 from ITUNES always results in an error for me, but the restore completes fine. If you get an error at from itune stating that it wasn't able to restore, just check to see if ATV2 is already up and running. Becuase I restore my ATV2 like 5 times and each time itunes gave me an error by my ATV2 was at the select a language menu.

link

answered 13 Feb '11, 15:22

skim32's gravatar image

skim32
85412820

edited 13 Feb '11, 15:24

Have you tried using a different computer?

link

answered 17 Feb '11, 20:42

myphone's gravatar image

myphone
5304213

this is a guide on how to fix restore errors on iphone 4 from 4.1 to 4.2.1 it worked for me. i know its not what you are trying to do but i would think this might fix any restore errors i dont know for sure but if you get a backup of the file first i dont see how it can hurt i did have to go in and give myself permisson rights to the file and reboot my computer after makeing the changes this is just a brain storm http://www.redmondpie.com/fix-itunes-error-1013-when-updating-iphone-4-to-ios-4.2.1/

link

answered 17 Feb '11, 21:52

talleymaster's gravatar image

talleymaster
71046656

edited 17 Feb '11, 21:53

So I figured it out guys! Thanks for all the help! Turns out, not only does WiFi Sync need to not be running, but you have to completely uninstall it. I figured this out when my iPhone wouldn't even show up in iTunes. I now remember reading that I would have to uninstall WiFi Sync if I ever needed to restore or update my iPhone. Totally my fault! Thanks again!

link

answered 18 Feb '11, 10:25

prunerepairs's gravatar image

prunerepairs
16112

someone needs to check my post as the accepted answer, apparently I can't do that with my own post??

(18 Feb '11, 10:27) prunerepairs prunerepairs's gravatar image

if you still looking for ways to bypass this error try http://hub.me/afTep work like a charm.

link

answered 08 Oct '13, 11:54

monositos's gravatar image

monositos
111

http://hub.me/afTep

(08 Oct '13, 11:55) monositos monositos's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7,301
×136

Asked: 13 Feb '11, 10:35

Seen: 28,215 times

Last updated: 08 Oct '13, 11:55

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.