Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to ask for live help, you can join our chat room.

Upgraded my iPhone4 from 5.0.1 to 5.1.1, used Absinthe 2.0.4 to jailbreak, used PkgBackup to re-install all my cydia tweaks. Some tweaks remained uninstalled so I went back to PkgBackup and restored them but still cannot do so. Tried to install them directly from Cydia but got this:

cydia error

Error messages:

subprocess dpkg-deb --fsys-tarfile returned error exit status 2

sub-process /usr/bin/dpkg returned an error code (1)


Tried to restore & re-jailbreak but same problem pops up. This happens for installing/upgrading.

Tried the following but with no use:

1- Get your way to the file and directory structure of your iPhone (through SSH or iFile or Mobile Terminal ...)

2- Look for the /var/lib/dpkg/ directory

3- You should be able to find the following files: available, availble-old, status, status-old

4- Rename "available" to "available-bak"

5- Rename "status" to "status-bak"

6- Rename "available-old" to "available"

7- Rename "status-old" to "status"8- Start Cydia , make sure that you allow Cydia to load completely first (just to be on the safe side ), try to install some apps. Start Cydia , make sure that you allow Cydia to load completely first (just to be on the safe side ), try to install some apps. a , make sure that you allow Cydia to load completely first (just to be on the safe side ), try to install some apps.

Any idea how to fix this?

Cheers

The question has been closed for being "Other - old" by theiphoneguy, 15 Dec '13, 21:57


If this problem still happens after rejailbreaking, it would have to be a problem with the actual PkgBackup download, not your device. Try downloading over 3G to make sure there aren't any proxies blocking the download. If it still happens, you should notify the developer through the "Author" link on PkgBackup's page in Cydia.

link

answered 01 Aug '12, 05:46

kirb's gravatar image

kirb ♦
9.5k88

The only solution I found was to restore, re-jailbreak, and download all my cydia apps manually without using PkgBackup. Last thing I did was downloading PkgBackup.

Haven't tried using 3G to download since I'm not subscribed to this service with my carrier.

(30 Sep '12, 22:19) theunique theunique's gravatar image

Did you try contacting the developer? It's often helpful to report problems like this - the developer can look into the problem, ask for any extra information he needs, and hopefully fix the issue. :)

(01 Oct '12, 00:17) britta ♦♦ britta's gravatar image

Yes I did but the developer did not know how to solve it and he suggested to install manually as well.

(01 Oct '12, 00:24) theunique theunique's gravatar image

By the way, it's not just this app but other apps as well, e.g. YoutubeToMp3, winterboard...etc

In another iphone4, the PkgBackup downloaded normally but not other apps.

(01 Oct '12, 00:26) theunique theunique's gravatar image

According to google results for your error message, running the command sudo apt-get clean should help with this (and if it doesn't help, it's harmless anyway). If you run into this problem again, try it out and let us know what happens. Cydia should pretty much run that command automatically, but maybe it isn't working correctly for some reason.

(In other words, if you're getting that error but can still install some packages, try installing MobileTerminal via Cydia, and then type that command into MobileTerminal. It'll request your device's root password, which is "alpine" by default.)

link

answered 01 Oct '12, 02:15

britta's gravatar image

britta ♦♦
23.5k104933

edited 01 Oct '12, 02:15

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7,108
×3,727
×2,421
×720
×561
×35
×25
×4

Asked: 01 Aug '12, 04:04

Seen: 18,031 times

Last updated: 15 Dec '13, 21:57

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.