Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

0
1

Reading the readme file with the new RC6 of Greenp0ison states that I need 4.2.1 installed. My AppleTV is at the latest and reports 4.1.1. It is NOT currently jailbroken from any other source. When I attempt to JB, I get into DFU mode, click the JB button and go through the steps. After a bit, it says "Jailbreak Failed :("

Is there a trick? Do I have to be pre-JBed to get it to work? Is there someway to test if it worked but I'm not seeing it?

Win7 64

asked 12 Feb '11, 20:33

chumad's gravatar image

chumad
1113

edited 12 Feb '11, 22:39

I'm having the same issue (Win7 64-bit). After I press "Jailbreak" I get an error in windows saying "USB Device Not Recognized". Then I get "jailbreak failed".

(12 Feb '11, 21:20) longsh0t longsh0t's gravatar image

12next »

What your AppleTV 2 Calls "4.1.1" is actually "4.2.1" (source: this article), so that should be okay.

When you start the jailbreak, make sure you are running it in Win XP SP3 Compatability Mode.

Also make sure you have active internet connection and have disabled any firewall and antivirus temporarily.

link

answered 12 Feb '11, 20:47

gomanski's gravatar image

gomanski
2.3k78

edited 12 Feb '11, 20:48

Does the JB take a while? I did as you instructed this time around and it is taking a lot longer. Been sitting on the Jailbreaking... message (with full green bar) for about 10 minutes now. Not sure if it's locked up or what?

(12 Feb '11, 21:06) chumad chumad's gravatar image

I think I remember seeing somewhere that that it should take longer than usual on the AppleTV, but that seems pretty excessive. I don't have an AppleTV2 myself, so I haven't tried personally.

(12 Feb '11, 21:13) gomanski gomanski's gravatar image

Well, it finally failed. Still no-go for me... any other ideas?

(12 Feb '11, 21:17) chumad chumad's gravatar image

Are you JB with mac or windows? There seems to be some issues with mac JB on the ATV2.

(12 Feb '11, 23:19) BentBanana BentBanana's gravatar image

Not sure if this is an official fix but I tried running the process without the power cable connected (just the USB connected). Did the DFU process (Menu+Play/Pause) and it jailbroke perfectly.

link

answered 13 Feb '11, 07:45

TheRealWB's gravatar image

TheRealWB
311

This worked perfectly for me! Thank you!


Running OSX 10.5.8

(13 Feb '11, 13:56) combatblimp combatblimp's gravatar image

Using this method (as compared to trying to plug in the power cord) it went through the process and said it completed successfully. However, I'm not able to connect to the ATV2 via SSH or tell in any other way whether the JB was actually successful.

Do I need to re-run the JB again ? or am I missing something else more fundamental ?

(13 Feb '11, 15:05) Spartacus Spartacus's gravatar image

Repeated steps from laptop running Win XP and it worked perfectly this time. After jailbreak, Greenpois0n shows up in the options and all's well :)

Was originally trying to do this from Win7 64bit.

(14 Feb '11, 06:48) Spartacus Spartacus's gravatar image

I had JB failed initially with GP RC6 and couldn't even restore in iTunes also. Keep getting error 14. After a lot of research online finally I was sure that my USB cable was the problem. I bought a new cable and restore/JB done in minutes.

link

answered 14 Feb '11, 12:42

hari's gravatar image

hari
161

http://pastebin.com/AsYkhVpm « I got the same problems,.. the app keeps failing or crashing when trying to jailbreak my device…

Anyone has a clue how to fix it?

link

answered 12 Feb '11, 21:46

hsl's gravatar image

hsl
1

1

How did you get the debug/log info?

(12 Feb '11, 22:04) chumad chumad's gravatar image

from the look of your log your pc isn't connected to the ATV. Are you using mac or windows? unplug all cables and then plug in the micro usb cable only. Wait for it to be recognised, then open up GP and go from there. If your using mac there are some issues. Seems to work fine on windows.

(12 Feb '11, 23:21) BentBanana BentBanana's gravatar image

I just a JB on my AppleTV 2 without any issues. I had it jailbroken but I did a full restore and had no issues. I let it sit after it said completed just to be sure.

link

answered 12 Feb '11, 23:24

wongalex's gravatar image

wongalex
151

can someone give me a clue as to how to run the jb from command line so that i can see a report. I'm on a mac and have the greepois0n sitting on my desktop. I have tried opening up a terminal window right clicking the gp icon on my desktop and selecting ' show package contents then in the new window opening the contents folder. then dragging the macos folder into my terminal window after put cd , now what do i do?

link

answered 13 Feb '11, 06:17

mccltd's gravatar image

mccltd
11

there is a new gp out for that. rc6. it's on the green pois0n website. that should jailbreak you. ohh and follow the instructions.

link

answered 13 Feb '11, 07:27

Paulmattes's gravatar image

Paulmattes
3014

I finally got my JB to work. Before when the green bar filled up, I'd get a notice in windows that my USB device failed to work. I plugged my microUSB cable into a new port, started GP and hit the "prepare" button, plugged in the ATV to the microUSB, then immediately held down the menu/pause buttons for 7 seconds. By the time GP told me to plug in my power (which I ignored), I let go of my menu/pause and GP immediately detected it in DFU mode (it skipped the remaining steps). I hit Jailbreak and it worked like a charm.

link

answered 13 Feb '11, 09:09

chumad's gravatar image

chumad
1113

And when you reboot after injecting software?

(14 Feb '11, 07:57) HellRaver HellRaver's gravatar image

i figured out somehow to go into dfu mode so the jailbreak button appeared in rc6 (the suggested way doesnt work at all)

however i receive the message "jailbreak failed :("

has anyone an idea what the reason could be or how can i check a logfile?

using w7 64b

link

answered 13 Feb '11, 11:02

xbmcfan's gravatar image

xbmcfan
1

i'll try it today gp told me it was successfully jailbroken but nothing happend if i switch it on to the tv. lets hope the usb cable is the case

link

answered 14 Feb '11, 13:05

xbmcfan's gravatar image

xbmcfan
1

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×138

Asked: 12 Feb '11, 20:33

Seen: 5,889 times

Last updated: 15 Mar '11, 23:11

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.