Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.x is released, still early stage, mostly for developers - see Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

I want to edit the dylibs because I know exactly what's causing the files, but I can't find out how to get to them. I can't SSH because it is never recognized by my computer in the boot process and the IV and Keys for the A5 devices haven't yet been released. What can I do?

asked 15 Jun '12, 17:05

jamesmusic52's gravatar image

jamesmusic52
11213

closed 03 Sep, 09:17

theiphoneguy's gravatar image

theiphoneguy ♦
37.6k55018

The question has been closed for being "Solved" by theiphoneguy, 03 Sep, 09:17


Jailbroken? Tried hard reboot + hold volume up?

link

answered 15 Jun '12, 19:46

justinred's gravatar image

justinred ♦
46.6k74217

Have you already tried the volume up button method to disable Mobile Substrate? You should also be able to connect to it over USB. See this guide to working with devices that won't boot:

Maybe you installed a very incompatible tweak? Try Mobile Substrate's safety feature: If that doesn't help, it could be that a tweak you installed before rebooting (even days before rebooting) is very incompatible with your version of iOS, which could cause a "boot loop" (getting the Apple logo over and over). Try forcing a reboot and then immediately holding down the Volume Up button as the device boots up. This will temporarily disable all extensions, as explained in the Mobile Substrate description.

Try manually removing very incompatible tweaks: If that doesn't help, or if your device is using an old version of Mobile Substrate (a version without the safety feature), try plugging your device into your computer and using an application such as iExplorer, DiskAid, or Phone Disk to access the device - it may be difficult to access a device in this state, but force a reboot and try accessing it. Check in the folder /Library/MobileSubstrate/DynamicLibraries/ and delete any extensions that might not be properly compatible with iOS 5, and then try booting again. (If any of your extensions happen to be pirated, those are good candidates for removal because pirated software is often outdated and buggy.) Try this until it works, or until you run out of patience. :)

link

answered 15 Jun '12, 19:48

britta's gravatar image

britta ♦♦
24.0k115134

I tried the Volume up trick and it didn't work. I held it for the whole about 15 minutes that it took to go through the loop. Nothing happened. I got the boot loop because I accidentally installed a siriport type thing from cydia that was only meant for 5.1 and I'm on 5.1.1 I tried WinSCP to see if it ever connected to my computer for a minute or two to try and delete the dylib for what I installed, but it never recognized. Then I tried USB SSH'ing but there are no IV or Keys for A5 devices. I can't think of any other was to get to the files.

(15 Jun '12, 21:49) jamesmusic52 jamesmusic52's gravatar image

Have you tried just connecting over USB (technically using afc2add) with iExplorer or a similar program? (Also yeah, Siri ports for iOS 5.1.x are very problematic.)

(16 Jun '12, 00:35) britta ♦♦ britta's gravatar image
2

Siriport=restoreville. It does too much to the filesystem to undo without restoring.

(16 Jun '12, 00:53) spockers ♦♦ spockers's gravatar image
1

After trying every single way I could find to try and get to the filesystem I just restored it. It wasn't being recognized, and without a bootrom exploit, there was no way that I could get in. Thanks for all your help guys!

(16 Jun '12, 05:41) jamesmusic52 jamesmusic52's gravatar image
-3

I have the same problem Jamesmusic52!

Please, tell me how did you solve it?

I can't afford to lose so many photos!!!

Thanks a lot!!

link

answered 03 Sep, 08:50

someone101's gravatar image

someone101
-191

Jamesmusic52 restored it, as stated installing siriports is extremely harmful as damage to file hierarchy is stretched beyond repair.

(03 Sep, 08:53) slavakulikoff slavakulikoff's gravatar image

p.s. dont post on 2+ year old questions.

(03 Sep, 09:16) theiphoneguy ♦ theiphoneguy's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×771
×319
×40

Asked: 15 Jun '12, 17:05

Seen: 6,140 times

Last updated: 03 Sep, 09:17

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.