Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Instructions for jailbreaking iOS 8.0-8.1.2. See /r/jailbreak on Reddit, @PanguTeam, and @TaiG_jailbreak for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

Hi I have the same problem with my 3GS. Stuck in dfu and error 21 on stock and custom firmware. I have tried all the above with no luck. Does anybody have any other ideas. Thanks

asked 04 Jun '12, 05:30

Scoobie13's gravatar image

Scoobie13
11112

converted to question 04 Jun '12, 21:19

britta's gravatar image

britta ♦♦
24.2k115135

Hi @Scoobie13! I converted your comment on this old question into your own question so that we can help you better. First, is this a normal iPhone 3GS or one with the iPad baseband? What iOS version was it on, and what were you trying to do?

(04 Jun '12, 21:22) britta ♦♦ britta's gravatar image

u may try tinyumbrella to kick out of DFU mode

Just open the tinyumbrella and press 'exit recovery'

(05 Jun '12, 02:30) abdullahkamran abdullahkamran's gravatar image

Hi it was not on iPad baseband and was on iOS 5.1. Was on charge one night and in the morning was dead. Plugged into my computer and iTunes said it was in recovery. I tried to restore and update to 5.1.1 but iTunes error 21. I have tried tinyumbrella it detects iPhone in dfu attemp to fix recovery with tinyumbrella and it reboots runs text and comes up with no data fetched and the something about 60000 ms giving up. I have tried many times to jailbreak with redsnow and comes up on the phone screen downloading jailbreak data runs text then continuously says please wait before the screen goes black and returns to dfu.

(05 Jun '12, 06:11) Scoobie13 Scoobie13's gravatar image

If its any help I'm now trying to restore iOS 4.1 through iTunes as I have read 4.1 is still signed by apple. It extracts the software, verifies with apple, prepairs iPhone for restore, on reboot screen goes white then error 21.

(05 Jun '12, 07:27) Scoobie13 Scoobie13's gravatar image

Your hosts file is wrong, probably due to TinyUmbrella. Click http://gs.apple.com and my guess is you'll get Cydia. In that case, open TinyUmbrella, Advanced tab, UNcheck "set hosts to cydia on exit." Close TinyUmbrella. Click the link again. If you get an Apple 404 page, you're all set. Close iTunes if open, open iTunes and click the restore button, this will put you on 5.1.1.

link

answered 05 Jun '12, 06:31

spockers's gravatar image

spockers ♦♦
60.7k349152

Hi thanks for the advice but it not that, I have just double checked that. Went straight to apple.com/404.

(05 Jun '12, 07:07) Scoobie13 Scoobie13's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1,524
×600
×14

Asked: 04 Jun '12, 05:30

Seen: 5,058 times

Last updated: 05 Jun '12, 07:27

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.