Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

How to jailbreak iOS 7.1-7.1.2 (using Pangu) or iOS 7.0-7.0.6 (using evasi0n7). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

0
1

hi guys, i had a jailbreaked and unlocked iphone 3gs with ios 4.1 or sth like that. i tried to upgrade to 5.0.1, i created custom ipsw, entered into pwned dfumode and manually restored from itunes. but while restarting it is stuck in black screen(no display) and whenever i connect it to pc, itunes says its in recovery mode and needs to restore. when i try to restore again, it shows error 1600. while creating ipsw, i clicked "no", which was some weeks made thing, which was supposed to be "yes" i guess. i tried to do it again, clicking "yes" but it needs to get into pwned DFU mode (even for recovery fix), now there's nth seen in my phone, i don't know its swithched on or off, i don't know how to enter into pwned dfu mode in this state? i tried tiny umbrella to download but it doesn't run, shows some error. i tried different versions, but all stated same error. so i haven't tried tinyumbrella! please help

asked 26 May '12, 01:57

Sudeep's gravatar image

Sudeep
11112


Do a forced reboot by holding power and home buttons until the apple logo appears.

link

answered 26 May '12, 02:07

iphpwn4's gravatar image

iphpwn4 ♦
12.9k99

edited 26 May '12, 02:08

yea, i tried it too, but it doesn't work too! i forgot to mention it earlier!

(26 May '12, 02:13) Sudeep Sudeep's gravatar image

Try these steps (written by @theiphoneguy):

Double dfu and 1600:

If you pwn dfu a device, then try to restore and get an error (3194, any error) the phone appears to stay in dfu mode. If you then pwn it again since its still in dfu and you can skip the buttons again, its now "dbl dfu" and double pwned and that doesnt work.

Resolution:

After the error, home+power for 10 seconds to force a reboot, then pwn it by tool of choice and hold the power, then power and home, then just home like normal. Then retry the restore

(26 May '12, 04:37) britta ♦♦ britta's gravatar image

thanx for the concern, but it doesn't work. there is nothing in the display, so i don't know, whats cooking inside this thing. i tried as u said, tried to reboot, and tried to pwn through redsnow(latest ver). But it says in order to proceed first connect to PC and then power off. i wish i could shout at it "how am i supposed to switch off the device which displays nothing". I'm sorry to bother you but i am in desperate need.

(26 May '12, 11:17) Sudeep Sudeep's gravatar image

If there's nothing on the display, that often means it's in DFU mode of some kind. Try holding down power and home to force turning it off at that stage.

(26 May '12, 17:34) britta ♦♦ britta's gravatar image

i tried it too....it looks as if the device restarts and again enters into recovery mode or stg like that. while doing so, the device gets disconnected from the itunes, then itunes tries to connect to it again and states "its in recovery mode, needs to be restored". doesn't restore and error 3194. yesterday it was showing 1600.

(26 May '12, 22:54) Sudeep Sudeep's gravatar image

Been there done that -- created an ipsw and loaded it to my 3GS but itunes would come up with different errors and stuff. I got stuck in recovery mode and it took me days to actually fix it when all you need to to do is run the latest redsnow and jailbreak it. Don't worry about the errors on itunes. After running redsnow, you're good to go.

link

answered 29 May '12, 03:57

jumords's gravatar image

jumords
113

edited 29 May '12, 03:57

but i've been using latest redsnow and for jilbreak, redsnow requires the phone to be swtched off and enter into DFU mode. The phone doesn't gets switched off and the "Next" button of redsnow doesn't activates. It doesn't work even if i tried to directly enter into DFU mode! :(

(29 May '12, 22:44) Sudeep Sudeep's gravatar image

Have you tried iREB? Run redsnow as administrator and try again.

(29 May '12, 23:59) jumords jumords's gravatar image

i've tried iREB. It doesn't work either.running redsnow as admin also doesn't work either.

(30 May '12, 12:26) Sudeep Sudeep's gravatar image

Have you tried setting compatibility modes for redsn0w too? See this guide.

(30 May '12, 22:31) britta ♦♦ britta's gravatar image

Download "TinyUmbrella"- http://thefirmwareumbrella.blogspot.com/?m=1- Open it up, connect your iDevice, and it should pop up on the sidebar in TinyUmbrella. It should then give you a few options such as "Enter Recovery" "Fix Recovery" "Exit Recovery". Try to fix recovery, and see if it boots up. If not then try to exit recovery. One of those should be able to kick you out of whatever mode you are in

link

answered 30 May '12, 07:41

Vote4Pedr0's gravatar image

Vote4Pedr0
54915524

there comes some hope....tinyumbrella took it out of recovery and boots. it shows some coding and ends with no istalled firmware found. Now i'm able to pwn dfu it. Again when i try to restore through itunes it shows 3194 error!!!

(30 May '12, 23:26) Sudeep Sudeep's gravatar image

The case of iPhone error 3194 is simple. Whenever Apple upgrades its firmware, any old firmware that exists does not get the necessary signing from Apple (signing of the ECID). This prompts the error to be displayed. The iPhone error 3194 is actually quite a simple issue which Cydia tried to overcome through its iTunes-based tricky maneuver. However, even that seems to fail when it comes to rectifying the error. Here’s how you can do it:

1. Manual Method:

-Open your hosts file. On Windows, this would be C:/Windows/System32/drivers/etc/ and on Mac, you can reach there through Go->Go To Folder->and type /etc.
-Once you have the hosts file open, at the end of the file, add this line:
#74.208.10.249 gs.apple.com
-Once you have appended the file with this line and saved it, restart your device and fire up iTunes for the restore. Hopefully, it would do the job!

2. Software – TinyUmbrella

If you think you are not good at tinkering with the hosts file, there is an alternative. But comparatively, both are same. For this method, you will have to download TinyUmbrella – works for both Windows and Mac. 
-Once you have the software, connect your iPhone through USB. Fire up the software. Make sure iTunes is not open at this point of time.
-There should be a Save SHSH button. TinyUmbrella will download SHSH Blobs from Cydia resources.
-Now click on Start TSS Server button.
-Check the Log tab. If you see ‘TSS Server Started!’ and ‘TSS Accepting Connections’ at the end of the Log, it means the work is done.
-Try to open gs.apple.com. If it redirects you to Cydia, it means you are now set to do the custom firmware downgrade or restoration.
-Launch iTunes and restore to the stock or custom IPSW.
(30 May '12, 23:45) Vote4Pedr0 Vote4Pedr0's gravatar image

Doing what I typed above (whatever method you choose, whether its to edit the host file, or run umbrella) would make your device restore. Hope this helps!

(30 May '12, 23:48) Vote4Pedr0 Vote4Pedr0's gravatar image

hey thanx, but dat was like incomplete info for me.....i did all those stuffs in tinyumbrella and then tried to restore. Should tinyumbrella be running while restoring? I tried by running TU while pwndfu+restoring (shows error 2005), closing TU while pwndfu+restoring (error 3194) and running TU while restoring(in this case i didn't entered phone into pwndfu mode and received error 2004, i guess, while preparing phone for restoring) in all the other cases i received error while verifying iphone restore with apple. this might be bothering you but please could help me providing detailed steps with to-dos and do-nots. Please

(31 May '12, 12:54) Sudeep Sudeep's gravatar image

TinyUmbrella should not be running while you try to restore your device, and your hosts file should be clean - see this guide to restore errors. If you want to restore your device to iOS 5.0.1, you have to use this method. If you want to restore your device to iOS 5.1.1, you have to make custom firmware (with redsn0w/sn0wbreeze/etc.), put your device into pwned DFU mode, and restore it.

(31 May '12, 19:43) britta ♦♦ britta's gravatar image

i tried dat too (3194) wat should i do?

(01 Jun '12, 01:03) Sudeep Sudeep's gravatar image

Find and pay the services of a professional to do it for you. ;)

(01 Jun '12, 01:24) justinred ♦ justinred's gravatar image

i've overcame these problem....now i can restore but after restoring, the device cannot reboot!!! its again stuck in recovery mode!! is this the problem like redsnow asks for ios XXXXXXX9A404 and the ios i have is xxxxxxxx9A405? i don't get 9A404 one over the net.

(01 Jun '12, 23:34) Sudeep Sudeep's gravatar image

@Sudeep If you're trying to get redsn0w to boot your device tethered, make sure that if you click Extras -> Select IPSW, you choose the stock IPSW instead of the custom IPSW.

(02 Jun '12, 22:18) britta ♦♦ britta's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×231
×72

Asked: 26 May '12, 01:57

Seen: 16,481 times

Last updated: 15 Jan '13, 22:24

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.