Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

I recently rejailbroke my iPhone 3G and upon visiting Cydia found that the Big Boss Repo wasn't showing any contents, I then tried adding another repo and recieved "Binzip2" error and the NODATA1 and NODATA2 but with BigBoss's address there. I then used DiskAid to go into the Cydia.list file and deleted Big Boss's information from it and added in the Big Boss.list file and i'm still getting the same error.

Can anyone help me out here? Preferably without rejailbreaking my phone, since I don't have wifi getting it unlocked is a bit of a pain in the arse, thank you!

asked 20 May '12, 19:31

napoleondance's gravatar image

napoleondance
11334


Delete the source and add the source back manually. That should do the trick

link

answered 20 May '12, 19:57

rouschmustang's gravatar image

rouschmustang
442501358

Will adding the source back through the 'add more sources' button on Cydia work? I've heard that the repos that are included in Cydia need different allowances than the repos that you manually add

(20 May '12, 20:02) napoleondance napoleondance's gravatar image

Try manually removing the BigBoss repo in Cydia through Manage>Sources>Edit and tap the red circle with the minus sign in it. Then hard reboot your device by holding power and home until the apple logo appears (10-15 seconds). Then open Cydia and on the opening screen tap "More Package Sources" and choose BigBoss repo. After it is installed check the "Changes" tab and refresh if still empty.

link

answered 20 May '12, 20:07

iphpwn4's gravatar image

iphpwn4 ♦
13.2k99

I tried that and got the following error:

Sub-process: /bin/bzip2 returned an error code (2)

GPG error: http://apt.thebigboss.org stable Release: The following signatures were invalid: NODATA 1 NODATA 2

Failed to fetch hyyp://apt.thebigboss.org/repofiles/cydia/dists/stable/main/binary-aphoneos-arm/Packages.bz2 Sub-process /bin/bzip2 returned an error code (2)

Some index files failed to download, they have been ignored or old ones used instead.

(20 May '12, 20:21) napoleondance napoleondance's gravatar image
-2

You cant delete BigBoss Repo as it is the main 1. so U need to reinstall CYdia with RedSn0w...

link

answered 21 May '12, 03:18

prajwal's gravatar image

prajwal
-44338

1

Cydia/Telesphoreo is the only repo you can't delete. Also, you cannot reinstall cydia with redsn0w, it will see that it's already there and not re-install it. Please do some minimal research before answering.

(21 May '12, 04:02) spockers ♦♦ spockers's gravatar image

sorry. I just gave him an idea that came in my mind

(21 May '12, 09:21) prajwal prajwal's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×135
×128
×64
×5
×3

Asked: 20 May '12, 19:31

Seen: 14,114 times

Last updated: 21 May '12, 09:21

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.