Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

iOS 9 and 8.4.1 do not have jailbreaks. You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
TaiG provides an iOS 8.4 and 8.3 untethered jailbreak. Check @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.


Hello, I just recently downgraded my iphone 4S from 5.1 to 5.0.1 and before i downgraded, I backup using itunes. Now when I try to restore from that backup after the downgrade, Itunes is saying that the software on the iphone is too old. Does anyone have an idea on how I can recover my data that i had before the downgrade without upgrading the firmware and losing the ability to jailbreak?

asked 11 May '12, 08:49

Coolcal45's gravatar image


closed 30 Jan '13, 22:03

britta's gravatar image


The question has been closed for being "Solved" by britta, 30 Jan '13, 22:03

Follow these simple steps :)

You must backup using iTunes, not iCloud.

If you've already backed up your data using iTunes, skip to step 3.

  1. If you did not Update to iOS 5.1.1 (-_-)"
  2. Backup your data using iTunes, not iCloud.
  3. After that, locate your backup on your computer.
  4. For Windows, it's at "C:/Documents and Settings/[USERNAME]/Application Data/Apple Computer/MobileSync/Backup". For Mac, it's "~/Library/Application Support/MobileSync/Backup"
  5. Locate your latest backup and search for the info.plist file. Edit it with a text editor and look for this string: <key>Product Version</key>
  6. Change 5.1 or 5.1.1 to 5.0.1 and save.
  7. You can now restore to this backup on 5.0.1.

answered 11 May '12, 10:36

kokhean's gravatar image


edited 11 May '12, 10:38


Thank You so much, it worked!

(11 May '12, 11:08) Coolcal45 Coolcal45's gravatar image

Interesting that it worked! I'd watch out for apps not behaving as expected - sometimes the backup from a newer version includes updated database structures, filenames, etc., that the older iOS version won't understand. Might work out OK in this case though, if things didn't change much from iOS 5.0.1 to 5.1.1.

(11 May '12, 19:44) britta britta's gravatar image

This directory does not exist on my MBP 10.7 "~/Library/Application Support/MobileSync/Backup"

I can get only as far as ~/Library/Application Support/


Edit: Google solved it!

(11 May '12, 22:50) kevinjm kevinjm's gravatar image

@kevinjm Can you explain the solution, or give us a link? It might help other people too. Thanks!

(11 May '12, 23:04) britta britta's gravatar image

@britta: For those experiencing problems navigating to this folder, it is hidden so press Option while clicking the Go menu in Finder ;)

(22 May '12, 21:06) iphpwn4 ♦ iphpwn4's gravatar image

Hi. I did this exactly. The problem is, now when I go to iTunes to restore from the backup, the backup file I edited is not in the iTunes drop down box.


answered 02 Oct '12, 06:43

Bodog's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 11 May '12, 08:49

Seen: 15,791 times

Last updated: 30 Jan '13, 22:03

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.