Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

evasi0n7 can jailbreak iOS 7.0-7.0.6 untethered. p0sixspwn can jailbreak iOS 6.1.3-6.1.5 untethered (see here for 6.1.6).
How to jailbreak iOS 7.0-7.0.6 (and fix problems). iOS 7.1 is not jailbreakable, except an unsupported tethered iPhone 4 jailbreak.
Restoring or updating will update your device to iOS 7.1 and remove your jailbreak. There is no way to downgrade from iOS 7.1 to 7.0.x.

Before asking a question, check Frequently Asked Questions to find quick answers!
If you'd like to chat, you can join us here (irc.freenode.net #JailbreakQA). Chat rules.

I did not back up. Yes, shame on me. However, I have 4000+ photos of my daughter that I need out. Right now, it's in recovery mode with that dreadful plug to iTunes icon. I tried Absinthe - does not recognize the phone - nothing happens. I tried limera1n - hangs up in DFU mode step. Trying redsn0w and it's complaining of "not supported in DFU mode" or "in recovery mode, try again...". Watched a gazillion youtube videos but nothing seems to work. I promise to back up as soon as I get in and get the photos. Please help!

asked 27 Apr '12, 12:13

thescream's gravatar image

thescream
26113

closed 26 Mar, 15:33

britta's gravatar image

britta ♦♦
21.3k94633

Not working... 1) can't seem to power off completely - keeps jumping back into recovery mode. 2) when I catch it in time to get to the DFU mode steps... On step 2, when I am holding the power and home button, it starts back up into recovery mode.

(27 Apr '12, 18:45) thescream thescream's gravatar image

So basically you were on 5.1 unjailbroken (of course) and got stuck in rec mode (you didn't say how) and now you are trying to jailbreak so you can recover files? There is NO 5.1 4s jailbreak.

(27 Apr '12, 19:28) justinred ♦ justinred's gravatar image

Yes, exactly. I am told by Apple recovery is the only option without even a looksee into the phone. Post installation of 5.1 about a month ago, the phone crashed a lot e.g., hang ups, reboot loops, photos with gray streaks, etc. I forced a hard reboot the other day when it hung up again. When it came back up, it got into the recovery mode.

Will there be a jailbreak for 5.1 4S released soon? There has to be a way to get the files out?

(27 Apr '12, 21:14) thescream thescream's gravatar image

The question has been closed for being "Spam magnet" by britta, 26 Mar, 15:33


for the iPhone 4s, redsnow doesnt recognize dfu mode, try a hard reboot pressing power and home button till u see the Apple logo

link

answered 27 Apr '12, 18:54

princedunet's gravatar image

princedunet
-4511

I know my phone is in DFU mode but redsn0w still says it's failed to get into DFU mode... arg?!

(27 Apr '12, 19:02) thescream thescream's gravatar image
2

Redsn0w isnt going to work on a 4S on 5.1

(27 Apr '12, 19:16) theiphoneguy ♦ theiphoneguy's gravatar image

Download this, run it in your command line like this: "s-irecovery -c setenv auto-boot=true" then "s-irecovery -c saveenv", after that do "s-irecovery -c reboot" and cross your fingers.

link

answered 29 Apr '12, 01:00

JonSeals's gravatar image

JonSeals ♦
15.8k471663

edited 29 Apr '12, 01:00

what does this do? and will it work for a ipad2 stuck in recovery mode from failed iOS update?

(01 Sep '13, 22:52) Gman2005 Gman2005's gravatar image

i had the same problem but i used redsnow and got myself out of recovery mode(by selecting "recovery fix" in "extras") if it didnt work use "pwned dfu" in "extras". first it will put ur device in "pwned dfu" mode and then use it again to go back to normal mode. let me know if it does work(it worked for me)

link

answered 27 Apr '12, 12:44

teddy's gravatar image

teddy
23827939

You used redsn0w fix recovery on a 4S?

(27 Apr '12, 13:23) theiphoneguy ♦ theiphoneguy's gravatar image

I used it with my iphone4 but it should also work with iphone 4s and ipad 2 coz the newest version of redsnow added the compatibiliy with A5 devices(iphone4s &ipad2)

(28 Apr '12, 04:04) teddy teddy's gravatar image
2

To jailbreak yes. Fix recovry needs a bootrom exploit. There is no bootrom exploit for a 4S

(28 Apr '12, 13:36) theiphoneguy ♦ theiphoneguy's gravatar image
-1

Do the opposite of putting it in DFU Mode..


  • Step 1) Hold the home button for 3 seconds

  • Step 2) do not release the home
    button,
    but also hold the power
    button for 15 seconds or until logo
    appears or disappears (depending on
    your situation)

  • Step 3) Let go of the home button,
    but keep holding the power button for 20-30 seconds or until RedsnOw
    or whichever program you're trying to do it with recognizes it and
    starts doing whatever it is you're
    trying to do.


I hope I helped, this got me out of recovery mode, but seeing as I am working on 5.1 iPod, using redsnOw it might be different... Oh and sorry, not sure which devices work with redsnOw so yeah, sorry for the confusion...Tell me how it goes.

link

answered 28 Apr '12, 01:16

HeyMe's gravatar image

HeyMe
443331441

edited 28 Apr '12, 22:34

Doesn't apply to an A5 device on 5.1, for which there is no jailbreak.

(28 Apr '12, 23:35) spockers ♦ spockers's gravatar image

Oh, sorry then. My bad...

(29 Apr '12, 14:47) HeyMe HeyMe's gravatar image
-2

redsnow is compatible with A5 versión 5.0 or 5.0.1 and must be in normal mode not in DFU, try fix the recovery with tiny umbrella, if not try hard reboot with power and home button

link

answered 28 Apr '12, 08:02

princedunet's gravatar image

princedunet
-4511

3

TinyUmbrella will not work. Like @theiphoneguy said, there is no bootrom exploit for a 4S.

(28 Apr '12, 23:36) spockers ♦ spockers's gravatar image

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×396
×131
×93

Asked: 27 Apr '12, 12:13

Seen: 22,428 times

Last updated: 26 Mar, 15:33

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.