Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu provides an iOS 9.0 untethered jailbreak. TaiG provides an iOS 8.4 and 8.3 untethered jailbreak.
Check @PanguTeam, @taig_jailbreak, @saurik, and /r/jailbreak for news and updates.
You can use Cydia Impactor if you need to un-jailbreak an 8.1-8.4 device without restoring.
Instructions for jailbreaking iOS 8.0-8.4.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems.

hey , i have a iphone 3gs on ios 5.0 tethered jailbroken with redsn0w on the ipad baseband and unlocked via ultrasn0w , i want to upgrade it to ios 5.0.1 for the untethered jailbreak , i have the stock ios 5.0.1 ipsw and a custom 5.0.1 ipsw as well created via redsn0w but apparently "that version of ipsw is not supported" -.- my question is how to i upgrade my phone to ios 5.0.1 because if i do it through itunes i get 5.1 and i dont have and saved shsh blobs to downgrade it , step by step instructions would be deeply appreciated (Im new to this).

one more thing i noticed is that redsn0w supports the stock ipsw if i select that ipsw via the redsn0w's select ipsw feature and then re - jailbreak my device will it be untethered on ios 5.0.1?(i currently have ios 5.0 i dont really know the purpose of downloading a ipsw file) and as i've read a stock ispw will remove the ipad baseband so if it does jailbreak my phone untethered will i be able to unlock it via SAM?

please help , Thanks\/

asked 23 Apr '12, 15:54

shakky's gravatar image


closed 10 Jan '14, 16:15

britta's gravatar image


Ibooty ftw. It must be what fixed it because I had the white screen into yellow fading away screen. Thought I had a brick until ibooty. Thanks Shakky.

(25 Nov '12, 18:35) wewk584 wewk584's gravatar image

The question has been closed for being "Old question (spam magnet)" by britta, 10 Jan '14, 16:15

If you want to upgrade your device to iOS 5.0.1, you need to have SHSH blobs saved for iOS 5.0.1, and you need to stitch the blobs into custom firmware. See this guide for detailed instructions on restoring to iOS 5.0.1. That's the only way to do it. It's a restore with custom firmware, so it won't interfere with the iPad baseband.

(There is no untethered jailbreak for iOS 5.0 unless you have an old-bootrom iPhone 3GS. You currently have a tethered jailbreak, which means that you have a new-bootrom iPhone 3GS.)


answered 23 Apr '12, 16:46

britta's gravatar image


edited 23 Apr '12, 16:48

Thankyou , I was impatient so i did a restore with the custom ios 5.0.1 ipsw without the blobs , everything is fine except whenever i try to reboot my device it goes into dfu mode once it is switched off and does not start unless i boot it with a tethered boot . otherwise it just does'nt boot at all please help i tried the redsn0w recovery fix already and it says downloading jailbreak data , then a list of commands appears and then the running pineapple icon appears for a milisecond and reads "rebooting" then my device turns off and goes into DFU mood again :-(it goes into DFU mood everytime the device is turned off regardless if it was a reoot or whatever .

(24 Apr '12, 05:22) shakky shakky's gravatar image

That happens when you force a restore to 5.0.1 without shsh blobs. As Britta said, no 5.0.1 shsh blobs, no 5.0.1 restore.

(24 Apr '12, 05:34) justinred ♦ justinred's gravatar image

what do i do now :( ? its doing something else now , now its not even booting through redsnow , the just boot option on redsnow , when i try it it goes through the process then on my device at first a white screen appears when redsnow is saying waiting for reboot , ad then a white screen with thin vertical lines appear on my device then when redsnow says done the white screen turns yellow with thin lines and slowly fades do you know what's happening? :S also if i restore it to 5.1 via itunes can i unlock my phone using SAM? i appreciate you people helping , seriously :)

(24 Apr '12, 12:29) shakky shakky's gravatar image

I believe that odd visual effect is caused by choosing the wrong option for "new (fixed) bootrom" or "older bootrom". Try again with redsn0w but choose the other option.

Yes, if you restore to iOS 5.1 and jailbreak it, you should be able to use the SAM-assisted method for unlocking. It doesn't work for everyone, but it's worth trying and we may be able to help get it working if you run into trouble.

(24 Apr '12, 15:55) britta britta's gravatar image

if i choose old bootroom it says your device does not support untether options and with the new bootroom this happens , whatever i try to do with my device this happens i even tried to restore it again via the stock and custom firmwares but to no avail , and one mistake i realized is that the custom ipsw i restored my phone to before , i made that for old bootroom devices via redsnow because my SN is somewhatxx011xxxxxx so i thought that my phone was made week 11 but i didnt know that the 0 represented 2010 anyway so i customized the ipsw for old bootroom and restored to it , that is why the it restored without shsh blobs , is this the cause of the problem?

(24 Apr '12, 15:59) shakky shakky's gravatar image

Since you have the iPad baseband, you need to restore with custom (no-baseband) firmware every time, not stock firmware. You can try making custom firmware based on the iOS 5.1 IPSW and then restore to that.

(24 Apr '12, 16:08) britta britta's gravatar image

oh and didnt read the second part of your comment :P imm so frustrated -.- anyway im downloading 5.1 ipsw from im going to try to restore it using that hope that would atleast get my phone running , and thanks for your help I appreciate it :) , also do you know what is itunes error 28 ? when i tried to re - restore my device on the same ipsw for the old boot room i restored it to before the same visual affect appeared and itunes gave me error 28 , apple forums said it error 28 was hardware error :(

(24 Apr '12, 16:11) shakky shakky's gravatar image

cant i restore it to stock firmware and unlock it on the stock baseband using SAM?

(24 Apr '12, 16:13) shakky shakky's gravatar image

iTunes errors can mean all kinds of things, but yeah, it sounds like error 28 is usually a hardware error. The iTunes Wiki says "The problem is a bad dock connector on the iPhone." It's still worth trying your other options before deciding it's a hardware problem.

With the iPad baseband, you have to use custom no-baseband firmware every time you restore. Stock iPhone 3GS firmware + weird iPad baseband = problems.

(24 Apr '12, 16:21) britta britta's gravatar image

OK thanks , any thoughts about the restore of the device to ipsw customized for oldbootroom devices ? think that could be causing the problem? and when i try to restore my phone to the custom ios 5.1 firmware what if the yellow screen shows up again? because so far my phone is in DFU mode and whatever i try to do either "just boot" or "recovery fix" or "jailbreak" this yellow screen appears every time after a white screen and then slowly fades , its creeping me out

(24 Apr '12, 16:27) shakky shakky's gravatar image

ok so here's the update, i downloaded the 5.1 firmware customized it , then tried to restore to it but still got the same results , first a white screen appeared which is plain white then thin vertical lines started fading into it , whilst itunes said "preparing iphone for restore" then the "pu - ung" sound that comes when entering DFU mode came and the screen turned yellow and started fading again then itunes gave error 28 again , i tried to fix recovery with tiny umbrella and the phone was stuck at the white screen for a while at this time i opened redsn0w and it showed Iphone 3gs (RECOVERY mode) instead of (DFU) so i think whilst its giving me the white and yellow screens it is in recovery mood , also tiny umbrella did not fix it , after a while on the white screen the yello screen appeared again , i tried it again and this time while it was on the white screen due to tiny umbrella i attempted a restore but still no avail , i closed tiny umbrella and put the device in pwned DFU mode via redsn0w and attempted a restore again this time when it came to the yellow screen i attempted a hard reset , the device went into DFU again and itunes gave error 1618 , i tried to restore again to the same old bootroom customized ipsw my phone is currently restored to and this time got a plain white screen , then a plain pale yellow screen , then device went into DFU again itunes error 28 my device just wont start at any cost , i even changed my dock cable , uninstalled itunes downloaded it again and reinstalled it , tried different versions of redsn0w to boot it but nothing is working , please help me , just get my device started somehow please i dont want a $300 paperweight.

(25 Apr '12, 04:38) shakky shakky's gravatar image

FInally FIXED :D:D:D ibooty solved it , atleast thats what i think :D i tried ibooty v 2.2 and it kept loading the green bar again and again after completing the process so i closed it and then when i tried the just boot it went successful , so did the restore to 5.1 , but now my phone is deactivated , like the configuration screen comes up and after i complete the configuration it says your phone can take upto x minutes to activate , then it says your sim is not supported , how do i activate my device , it is unjailbroken i tried to jailbreak with redsn0w but it crashed .


answered 25 Apr '12, 09:02

shakky's gravatar image


all done , rebooted the laptop and it worked , unlocked it with ultrasn0w and ultrasn0w fixer for 5.1 phone is working , thankyouu :D

(26 Apr '12, 07:45) shakky shakky's gravatar image

@shakky please tell what u did. I have an Iphone 3GSon iOS 4.1 with baseband 6.15.00. Please tell me what u did step by step. Please!!!


answered 29 Apr '13, 01:55

leander's gravatar image


Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 23 Apr '12, 15:54

Seen: 4,432 times

Last updated: 10 Jan '14, 16:15

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.