Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

There is no jailbreak for iOS 8 yet. How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.
Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.
If you tap "Update" in the App Store and the app opens instead of updating, this is an Apple bug instead of anything related to your jailbreak.

I'm new to jailbreaking, so I followed the guide on this website very carefully. I have a 4th generation iPod Touch (5.0.1). After jailbreaking successfully and trying it out, I now want to remove the jailbreak. I found the FAQ about this, which says to use iTunes to first bakup then restore the iPod. The 1st problem I'm having is that when iTunes tries to restore the device, it warns me that the latest iOS (5.1) will be installed. Having read the FAQ on this site about SHSH, I know that it's unwise to upgrade to 5.1 if I ever think I will need to jailbreak again (which I might want to do). Therefore, I believe it's recommended that I save my SHSH to my computer in case I want to revert back to 5.0.1. So, I tried following the directions using TinyUmbrella with these options:

[ ] UPDATE iPHONE 4 BASEBAND
[X] Save ALL Available SHSH
[ ] Set Hosts to Cydia on Exit
[X] Request SHSH From Cydia
[X] Overwrite exiting SHSH files on "Save SHSH"
[X] When connecting a device, prefer my custom device name over the name set on the device

After doing this, I tried going into the terminal to see if it saved any files (using ls -la). The only file I saw was .cache/lib-osx.jar. When I go to the Log tab in TinyUmbrella, I see the following:

04/22/2012 11:47:30.165 CYDIA DOES NOT HAVE YOUR SHSH FOR iPod4G 5.1b1 (9B5117b) THERE IS NO WAY FOR YOU TO GET THEM. SORRY. YOU ARE JUST TOO LATE.
04/22/2012 11:47:30.315 For version [iPod4G 5.1b2 (9B5127c)] - This device isn't eligible for the requested build. 04/22/2012 11:47:31.846 Finished saving SHSHs for [Main’s iPod]
04/22/2012 11:47:32.017 Caching shsh files...
04/22/2012 11:47:32.034 Found [0] shsh files to cache...
04/22/2012 11:47:32.049 Cached [0] shsh files

So, as you can see from the log, it seems like it hasn't stored the SHSH files.

Questions:

  1. Does Cydia not have my SHSH because I did something wrong during the jailbreak process?
  2. If so, is there any way to fix it?
  3. Is there any other way to get the SHSH for this device?
  4. Instead of having to deal with iTunes and the auto-upgrade, and because I have no important data on the iPod, could I just restore from the device itself? (I.e. Settings > General > Reset > Erase All Content and Settings) Or could this mess up the iPod completely?

Other Info:

  • I have nothing important on my iPod, so I don't care if all the data is wiped.
  • Ideally, I want an non-jailbroken iPod with 5.0.1 running. If that's not possible, then I would want a non-jailbroken iPod 5.1 with 5.0.1 SHSH files saved, so that I can restore to 5.0.1 if I need to.

asked 22 Apr '12, 15:17

jr345's gravatar image

jr345
36115

edited 22 Apr '12, 15:53


For #1-3: You probably did the jailbreaking process correctly, but Cydia couldn't save your blobs since Apple is no longer signing iOS 5.0.1. You can investigate grabbing partial blobs using redsn0w or iFaith. See this guide to SHSH blobs - I'll quote the most relevant bits:

Apple's "signing" of each iOS version only lasts for a limited time, usually just for as long as that iOS version is the latest version available. Once Apple stops signing the SHSH for an iOS version, there is no way to restore that version again, unless you have SHSH blobs saved for that version (see below for the exception of A5 devices).

Cydia automatically tries to save any available SHSH from Apple each time you open Cydia. TinyUmbrella is a free tool that can save SHSH for devices (and can help you upgrade or downgrade to a specific version of iOS 4.x if you have SHSH saved for that version). The SHSH blobs that you can grab depends only on which versions Apple's servers are signing at the moment; it doesn't have anything to do with the version of iOS currently on your device. (However, redsn0w and iFaith can grab "partial blobs" off some devices, which you can use to "stitch" a pre-signed IPSW, which is useful if your device is on an iOS version that Apple is no longer signing, but you want to be able to restore to that version later. A guide to using iFaith.)

For #4: You can't use "Erase all content and settings" on a jailbroken device - because of the different filesystem on a jailbroken device, tapping that button messes things up and causes your device to get stuck at the Apple logo while booting - meaning that you'll have to restore with iTunes anyway.

link

answered 22 Apr '12, 16:56

britta's gravatar image

britta ♦♦
24.0k115134

Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×999
×604

Asked: 22 Apr '12, 15:17

Seen: 8,836 times

Last updated: 22 Apr '12, 16:56

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.