Help with jailbreaking and Cydia for iPhones, iPads, and iPod touches.

Pangu for iOS 8.0-8.1 is released (instructions) - see /r/jailbreak on Reddit or @PanguTeam for updates.
How to jailbreak iOS 7.1-7.1.2 (using Pangu). How to jailbreak iOS 6.0-6.1.6.

Before asking a question, check Frequently Asked Questions to find quick answers!
How to fix some mysterious problems. If you'd like to ask for live help, you can join our chat room.

0
1

iPod touch 4, iOS 4.3.1. Restored with custom ipsw (signed) made by sn0wbreeze 2.9.3. Can anyone tell me it's sn0wbreeze's problem or what? I could install mobile substrate and it did work after respring, but after reboot, mobile substrate just don't work, it seems to be in normal mode because I can't get into safe mode. Can anybody solve this?

Syslog link.

asked 18 Apr '12, 00:20

lp6216's gravatar image

lp6216
0447

edited 18 Apr '12, 04:46

britta's gravatar image

britta ♦♦
24.1k115135

Why are you on 4.3.1? DONT UPGRADE first of all :P

(18 Apr '12, 00:21) Haifisch Haifisch's gravatar image

There's nothing wrong with using 4.3.1, really.

(18 Apr '12, 00:26) britta ♦♦ britta's gravatar image

Well I have 4.3.5 and 5.0.1, 5.1's SHSH, I just don't wanna be in iOS 5 or a tethered JB. I saved 4.3.1 SHSH by iFaith.

(18 Apr '12, 00:26) lp6216 lp6216's gravatar image

Britta i know ._.

(18 Apr '12, 00:28) Haifisch Haifisch's gravatar image

YouMail works on 4.3.1 which is cool ;-)

(20 Apr '12, 00:15) JuergenWest ♦ JuergenWest's gravatar image

It sounds like you managed to boot up with Substrate disabled. The new version of Substrate includes a feature where if you hold down the volume up button while rebooting, Substrate is disabled in order to help you uninstall problematic tweaks if you need to. Maybe that happened in this case somehow? Can you try rebooting again?

link

answered 18 Apr '12, 00:26

britta's gravatar image

britta ♦♦
24.1k115135

I didn't touch the volume button while booting. I rebooted, mobile substrate failed to work. Maybe I can try install older version of mobile substrate?

(18 Apr '12, 00:31) lp6216 lp6216's gravatar image

Did you try rebooting again once or twice, just to see if it was an isolated event? Also, can you check to make sure that Substrate Safe Mode is installed in Cydia? If it still doesn't work, installing an old version of Mobile Substrate could be an interesting experiment.

(18 Apr '12, 00:52) britta ♦♦ britta's gravatar image

I've already tried several times before asking this question. And installing older version seems to be useless.

(18 Apr '12, 01:17) lp6216 lp6216's gravatar image

What leads you to believe it's not working? You said mobile substrate just don't work, it seems to be in normal mode because I can't get into safe mode. Why and how are you trying to get into safe mode?

(18 Apr '12, 01:31) spockers ♦♦ spockers's gravatar image

There's no safe mode to go and no way to go. Any tweaks that uses mobile substrate don't work, such as SBSettings.

(18 Apr '12, 01:35) lp6216 lp6216's gravatar image

What method did you use to install an older version?

(18 Apr '12, 01:39) britta ♦♦ britta's gravatar image

iFile

(18 Apr '12, 01:40) lp6216 lp6216's gravatar image

Which older version did you install? Did you reboot after installing it?

(18 Apr '12, 01:43) britta ♦♦ britta's gravatar image

0.9.3995

(18 Apr '12, 01:43) lp6216 lp6216's gravatar image

So you installed 0.9.3995, and that did not help? Were you previously using 0.9.3995? Maybe I could get a syslog?

(18 Apr '12, 02:24) saurik ♦♦ saurik's gravatar image

Actually, I just restored it yesterday so it isn't upgraded from any version, it's newly installed. 0.9.3995 didn't help. Wait a minute for me to post syslog.

(18 Apr '12, 03:27) lp6216 lp6216's gravatar image

(Just a note to say I edited your post to link to the syslog instead of including it - the JailbreakQA formatting doesn't handle large blocks of syslogs very well. :) )

(18 Apr '12, 04:49) britta ♦♦ britta's gravatar image

Thank you.

(18 Apr '12, 04:52) lp6216 lp6216's gravatar image

To verify, that is sn0wbreeze, not JailbreakMe? I wonder if it is using the same exploit as JailbreakMe... do you use Cydia often? To expand on my question regarding 3995: do you think that you had upgraded Substrate in the last few months to 3995? I am trying to figure out if there is any chance that when it worked you were using 390x instead of 399x. Can you tell me if there is a file /etc/dirhelper, and if so what is in it? Most importantly: is /etc/dirhelper a symlink, and if it is what is the file a symlink to? I don't know of any developer that uses sn0wbreeze, so Substrate probably gets no testing on that jailbreak. (However, based on the "I exist.", I would think that it is something comex did, and comex's JailbreakMe 3.0 is not really supported by Substrate: I have some compatibility logic that detects JailbreakMe 3.0 and treats it as a "buggy jailbreak kernel"; it might be that sn0wbreeze adapted components from JailbreakMe 3.0 but did not look similar enough for me to blacklist it?)

(18 Apr '12, 04:58) saurik ♦♦ saurik's gravatar image

Yes, it's sn0wbreeze. I think it's 3995 or 3996 because mobile substrate was the latest version before I restore, mobile substrate just updated few days ago, right? Before I restore I was on 5.0.1 jailbroken by redsn0w.

(18 Apr '12, 19:37) lp6216 lp6216's gravatar image

No, I am asking about the version of Substrate you were using /before/ you did the update from a few days ago. The previous public release of Substrate was 3995 which was from a few months ago. I am asking whether you use Cydia sufficiently often and accept the updates it prompts you to install sufficiently often that I can presume that 3995 was the version you previously had that worked, or whether you were actually using 3901, which is from the previous "generation" of Substrate architecture. The behavior you describe is just so dramatic, with absolutely nothing working, that it is difficult to believe it was caused by one of the minor changes between 3995 and 3997 (the version released a few days ago). Regardless, I also really am curious about the behavior of /etc/dirhelper on disk: that is what I will need to know about sn0wbreeze for 4.3.1 to figure out whether I need to detect it as a "buggy jailbreak" in the same way I do for JailbreakMe 3.0.

(18 Apr '12, 20:12) saurik ♦♦ saurik's gravatar image

For all 4.3 - 4.3.3 releases of iOS, I used comex's untether whenever possible. But I didn't include the unionfs stuff. His untether is added to /usr/libexec/dirhelper. I believe with jbme 3, dirhelper is symlink'd to /boot/untether. Hope this helps.

(18 Apr '12, 20:31) iH8sn0w iH8sn0w's gravatar image

I do use Cydia often, and I hate the badge on it so I'm pretty sure it should be the previous version, maybe even 3997 but in 5.0.1 at that time. I didn't found dirhelper in etc, so I searched it and found it in /var/stash/libexec. What do you want? The file?

(18 Apr '12, 20:31) lp6216 lp6216's gravatar image

By the way, I have a 4.3.3 iPod touch 3 also jailbroken by sn0wbreeze and I can't find dirhelper. Can anyone tell me what's that for? And just to mention, sn0wbreeze has a problem that causes respring everytime when switch to Chinese keyboard on 5.0.1. I'm sure that's sn0wbreeze's problem because if the device was jailbroken by resn0w, there's no problem like this, but to be honest, sn0wbreeze is really a covenient tool. (Please forgive me if there is any grammar problem))

(18 Apr '12, 21:34) lp6216 lp6216's gravatar image

@iH8sn0w: Thanks! The way I detect comex's untether (which has the problem that it is run "too late" for Substrate to engage launchd with the newer safer injector) is to readlink("/usr/libexec/dirhelper") and see if it is linked to "/boot/untether". Do you remember if sn0wbreeze on 4.3.1 includes the dirhelper script, but does not have it as a symlink?

(18 Apr '12, 23:49) saurik ♦♦ saurik's gravatar image

@saurik I do not symlink /usr/libexec/dirhelper to anything. The untether is the binary 'dirhelper' in /usr/libexec.

(19 Apr '12, 00:41) iH8sn0w iH8sn0w's gravatar image

@iH8sn0w Damn. Ok, I guess I could check its MD5 or something... is the contents of the file identical to the /boot/untether that is shipped by comex?

(19 Apr '12, 16:02) saurik ♦♦ saurik's gravatar image

@lp6216 Due to this you will need to use Substrate 0.9.390x (as opposed to 0.9.399x): the "x" can be anything. I think the latest release of that series of Substrate was 0.9.3901, available here: http://apt.saurik.com/debs/mobilesubstrate_0.9.3901_iphoneos-arm.deb

(19 Apr '12, 16:03) saurik ♦♦ saurik's gravatar image

@iH8sn0w (Actually, was the file different on different device/firmware combinations? Is there even a good md5sum I could compare it to? Were people compiling their own copies and going to end up with slightly different values?)

(19 Apr '12, 16:14) saurik ♦♦ saurik's gravatar image

Interesting reading. So if a device is on 4.x.x and used jailbreakme, it's advisable to restore (rip the blob's, by shsh, etc) and jailbreak not by jailbreakme?

(19 Apr '12, 16:22) theiphoneguy ♦ theiphoneguy's gravatar image
1

@theiphoneguy Yes and no: in this case, sn0wbreeze has the same problem as it is using the same underlying untether. The problem is that comex used dirhelper rather than launchd.conf or another earlier-to-execute mechanism when he built that jailbreak, but I ended up relying on launchd.conf for purposes of Substrate (sadly, I believe I knew that that would happen at the time, but I was not involved in that jailbreak). The result is that Substrate has to use the "old injector" on devices with that jailbreak, which does not support hooking as many daemons, does not support semi-tethering, does not support "volume up to disable", is much more difficult to manually uninstall in a pinch, and requires reboots every time you do just about anything to it (such as upgrading the package). That said, sn0wbreeze has the advantage that because it does not use unionfs, users can "fix" their jailbreak by renaming dirhelper to something else (such as untether) and then adding "bsexec .. /usr/libexec/untether -machineBoot" to the top of their launchd.conf (this does not work with JailbreakMe 3.0, as the launchd.conf ends up being underneath the union mount, so it cannot easily be edited; had I been able to edit it I may have simply opted to have Substrate "upgrade" users' jailbreaks when I ran into this problem). FWIW: the other jailbreaks I do not fully support are "PwnageTool (maybe everything...) on iOS 2.x" (I drop down to the old injector as I detect during installation that once a process forks I can no long execute modified code; this actually causes instabilities in other places) and "greenpois0n on iOS 4.1 (at least on a 2G iPod touch MC" (which is so bad that just running "ps" spontaneously reboots the device, as does even attempting to install Substrate 399x).

(19 Apr '12, 18:49) saurik ♦♦ saurik's gravatar image

@saurik ty for the tips. Just dont want to get some poor users jailbreak in a bad spot down the road knowing that info

(19 Apr '12, 19:05) theiphoneguy ♦ theiphoneguy's gravatar image

Wow, it works. I "fixed" it, as you said, rename and add the line to top of launchd.conf and reboot. Thanks for you all's help, I really admire you guys. Did older version use differnent jailbreak? iPod touch 3 on 4.3.3 which was also jailbroken by sn0wbreeze (but a older version, 2.7.x or what) doesn't have this problem and can use 399x flawlessly. I'm really interested in these things. Where can I find some knowledge about this?

(19 Apr '12, 21:48) lp6216 lp6216's gravatar image

@saurik You should be able to compare it to comex's binaries no problem since I didn't recompile them.

(20 Apr '12, 00:03) iH8sn0w iH8sn0w's gravatar image

@lp6216 There were some device/4.3.x combos that comex did not publicly redistribute untethers for. Therefore, I used i0n1c's untether in those situations.

(20 Apr '12, 00:04) iH8sn0w iH8sn0w's gravatar image

Hi How do you edit the launchd ? I have exactly the same issue.

link

answered 14 Jun '12, 04:45

Wooosh's gravatar image

Wooosh
112

edited 14 Jun '12, 04:46

@Wooosh If you have a device with this kind of bizarre jailbreak, it may be best to just restore to a more recent iOS version and jailbreak it again with redsn0w or Absinthe. If you're willing to do that, let us know which device and iOS version you're using, and whether you use an unofficial carrier unlock of some kind, and we can try to help with the upgrading process. Also see this guide to upgrading steps.

(14 Jun '12, 14:28) britta ♦♦ britta's gravatar image

Thank you for helping. In fact I have restored with iOS 5.1.1 and had an Absinthe 2.0.4 jailbreak. ( IPhone 4)

The weird thing is that I can boot unthetered, can respring anytime with cydia tweaks ok, but in the case of rebooting, mobile substrate is killed. Of course I am not disabling it with the up volume button, So i have left a mobilesubstrate deb that I reinstall with Ifile in the case I have a reboot and things are ok, until the device reboot; wich I am trying to avoid as much as I can.

ReJB with absinthe shows my device has been already jailbroken ( witch is right :) ) and I am not willing to JB in another way, since I do not know what will be the result with a JB over another one. A full restore represent too much work to reinstall tweaks for this annoying but fixable bug.
Thank you

(14 Jun '12, 16:48) Wooosh Wooosh's gravatar image

@Wooosh Strange! It might be interesting to try to figure out the cause of this problem. Has this been happening since you jailbroke it on iOS 5.1.1? Do you have any unusual packages installed?

(14 Jun '12, 17:17) britta ♦♦ britta's gravatar image

Hmmm I am not absolutely sure it does it since the very beginning of my 5.1.1 JB. I would say yes but can be sure . I am trying to link the bug to a particular tweak , kind of a difficult thing since I do not have a precise date of the trouble. I may try to use some restore images I have with pkg backup or remove and try without one of the last tweaks installed , nothing extraordinary to me Crash log doesn't learn me more about it. ( but I am not a specialist)

(14 Jun '12, 18:10) Wooosh Wooosh's gravatar image

@Wooosh Would you mind following these instructions to get a copy of syslog from your device? Do those steps, reboot your device to enable syslog, and then reboot it again to make sure that the interesting Substrate disabling behavior is recorded in the syslog. Then email the result to me at britta@saurikit.com. We'll see if it has any clues to what's causing the problem. Thanks!

(14 Jun '12, 20:23) britta ♦♦ britta's gravatar image

done ; thank you for all

(15 Jun '12, 01:29) Wooosh Wooosh's gravatar image

@Wooosh Thanks for sending it! Can you try booting tethered with redsn0w, and then send the syslog again?

(15 Jun '12, 02:47) britta ♦♦ britta's gravatar image

okay

tethered boot provided : - animate logo screen witch wasn't while unthetered , and mobilesubstrate functionnal this time o-0

syslog sent . Thank you.

(15 Jun '12, 03:01) Wooosh Wooosh's gravatar image

@britta Your suggestion and the fact that tethered boot was working gave me an idea : I tried to reinstall Rocky Racoon despite it was checked in Cydia. I had a normal startup this time.

Hopefully that fixed the thing ..

Thank you

(15 Jun '12, 04:28) Wooosh Wooosh's gravatar image

Interesting. I don't quite understand why that helped, but I'm glad it's working as expected now.

(15 Jun '12, 05:20) britta ♦♦ britta's gravatar image

I have an interesting situation, after a slight mishap with my iphone (semi-drowned it), iphone has been booting up with mobile substrate disabled. Realized this after trying to run activator and it gave an error message. Now here is the kicker, since the mishap the volume up button seems to be constantly engaged and it definitely boots with it engaged as when the phone re-starts the volume status bar is on screen and increasing. As i have discovered in this thread, this is a new safety feature of mobile substrate, but one i definitely do not want. Can i disable this feature or how do i install an older version?

(03 Oct '12, 14:22) tonirags tonirags's gravatar image

You probly want to fix the water damage as it will have other issues

(03 Oct '12, 14:42) theiphoneguy ♦ theiphoneguy's gravatar image

figured out how to downgrade mobile substrate...phone is working fine now!! have selected the option in cydia never to upgrade! woo hoo! thanks you all, your discussion helped tremendously!!!

(03 Oct '12, 14:55) tonirags tonirags's gravatar image
Your answer: (please use the "add new comment" button unless you are actually answering the original question)
toggle preview

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×228
×212

Asked: 18 Apr '12, 00:20

Seen: 6,913 times

Last updated: 03 Oct '12, 14:55

JailbreakQA is by chpwn and comex.
About JailbreakQA. Powered by OSQA.